Is It A Tree?

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29669    Accepted Submission(s): 6811


 

Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 

 

 

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 

 

 

Output

For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 

 

 

Sample Input

 

6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1

 

 

Sample Output

 

Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.

 

 

Source

North Central North America 1997

 

 

Recommend

Ignatius.L

 #include<iostream>
#include<algorithm>
#include<map>
using namespace std;
#define max 1000010
struct kk
{
    int root,in,num;
}a[max];
void init()
{
    for(int i=0;i<max;i++)
    {
        a[i].root=i;
        a[i].in=0;
        a[i].num=0;
    }
}
int find(int x)
{
    return x==a[x].root?x:a[x].root=find(a[x].root);
}
int join(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
    {
        //cout<<x<<" "<<y<<"  "<<fx<<"  "<<fy<<endl;
        a[fy].root=fx;
        return 1;
    }
    return 0;
}
int main()
{
    int x,y,i,j,t=1,k=0,f=0;
    init();
    while(~scanf("%d%d",&x,&y),x>=0&&y>=0)
    {
        if(x==0&&y==0)
        {
            for(i=1;i<=max;i++)
            {
                if(a[i].num&&a[i].root==i)
                k++;
                if(a[i].in>1)
                {
                    f=1;
                    
                    break;
                }
            }
            if(k>1)
            f=1;
            if(f==1)
            printf("Case %d is not a tree.\n",t++);
            else
            printf("Case %d is a tree.\n",t++);
            f=0;
            k=0;
            init();
        }
        if(x!=y&&find(x)==find(y))
        {
            f=1;
        }
        else
        {
            a[x].num=a[y].num=1;
            a[y].in++;
            join(x,y);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
## Problem 7: Is BST Write a function `is_bst`, which takes a Tree `t` and returns `True` if, and only if, `t` is a valid binary search tree, which means that: - Each node has at most two children (a leaf is automatically a valid binary search tree). - The children are valid binary search trees. - For every node, the entries in that node's left child are less than or equal to the label of the node. - For every node, the entries in that node's right child are greater than the label of the node. An example of a BST is: ![bst](pic/bst.png) Note that, if a node has only one child, that child could be considered either the left or right child. You should take this into consideration. Hint: It may be helpful to write helper functions `bst_min` and `bst_max` that return the minimum and maximum, respectively, of a Tree if it is a valid binary search tree. ```python def is_bst(t): """Returns True if the Tree t has the structure of a valid BST. >>> t1 = Tree(6, [Tree(2, [Tree(1), Tree(4)]), Tree(7, [Tree(7), Tree(8)])]) >>> is_bst(t1) True >>> t2 = Tree(8, [Tree(2, [Tree(9), Tree(1)]), Tree(3, [Tree(6)]), Tree(5)]) >>> is_bst(t2) False >>> t3 = Tree(6, [Tree(2, [Tree(4), Tree(1)]), Tree(7, [Tree(7), Tree(8)])]) >>> is_bst(t3) False >>> t4 = Tree(1, [Tree(2, [Tree(3, [Tree(4)])])]) >>> is_bst(t4) True >>> t5 = Tree(1, [Tree(0, [Tree(-1, [Tree(-2)])])]) >>> is_bst(t5) True >>> t6 = Tree(1, [Tree(4, [Tree(2, [Tree(3)])])]) >>> is_bst(t6) True >>> t7 = Tree(2, [Tree(1, [Tree(5)]), Tree(4)]) >>> is_bst(t7) False """ "*** YOUR CODE HERE ***" ``` 。
06-03

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值