[C++] 1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

 

Sample Output:

3 2 1.5 1 2.9 0 3.2

 这道题挺有意思的一个小波折是我最初考虑到正负相加为0的情况但是看到题目说N全大于0就以为系数全正就把判0去掉了,结果提交后后半部分测试点全WA(所以后几个测试点都是有正负相加0的情况)。然后又改回来AC了。

ps.这道题我的耗时比柳神快所以请允许我嘚瑟一会。我是用的map来存储数据。

#include <bits/stdc++.h>
#include <map>
using namespace std;

int main() {
	int k;
	map<int, double> mp;
	cin>>k;
	int tk, max = 0;
	double dv;
	for (int i = 0; i < k; i++) {
		cin>>tk>>dv;
		if (max < tk) max = tk;
		mp[tk] = dv;
	}
	cin>>k;
	for (int i = 0; i < k; i++) {
		cin>>tk>>dv;
		if (max < tk) max = tk;
		if (mp.count(tk) > 0) {
			mp[tk] += dv;
			if (mp[tk] == 0) mp.erase(tk);		//最开始写上了,后来注释掉,后来又加上 
		} else 
			mp[tk] = dv;
	}
	printf("%d", mp.size());
	for (int i = max; i >= 0; i--) 
		if (mp.count(i) > 0) printf(" %d %.1lf", i, mp[i]);
	return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值