HDU-2054 A == B ?

11 篇文章 0 订阅
7 篇文章 0 订阅

A == B ?

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 122472    Accepted Submission(s): 19573


Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
 
 
1 2 2 2 3 3 4 3
 
Sample Output
 
  
NO YES YES NO
#include<iostream>
#include<string.h>
using namespace std;
char a[20000],b[20000];
void change(char* a)
{
	int i,n=strlen(a);
	if(strstr(a,"."))
	{
		for(i=n-1;a[i]=='0';i--)
		{
			a[i]='\0';
			n--;
		}
	}
	if(a[n-1]=='.')
	a[n-1]='\0';
}
int main()
{
	while(cin>>a>>b)
	{
		change(a);
		change(b);
		if(strcmp(a,b))
		cout<<"NO"<<endl;
		else cout<<"YES"<<endl;	
	}	
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值