K - The Marshtomp has seen it all before HihoCoder - 1082

fjxmlhx不喜欢网上的 marshtomps 。所以他决定把所有的 “marshtomp”(名字不区分大小写) 改为 “fjxmlhx;

Input

输入包含多行,每行字符串不超过200的长度,一个单词不会一半出现在上一行,剩下的在下一行。直到文件结束(EOF)

Output

输出 替换之后的字符串。

Sample Input
The Marshtomp has seen it all before.
marshTomp is beaten by fjxmlhx!
AmarshtompB
Sample Output
The fjxmlhx has seen it all before.
fjxmlhx is beaten by fjxmlhx!
AfjxmlhxB

#include<iostream>
#include<string.h>
using namespace std;
char s[10005];
char st[100]="marshtomp";
char st1[100]="fjxmlhx$$";
char c[100];
int main()
{ 
	int i,j,pos,p,q;
	while(gets(s))
	{
	int n=strlen(s);
	for(i=0;i<n;i++)
	{
		if(s[i]=='m'||s[i]=='M')
		{
			memset(c,0,sizeof(c));
			pos=i;
			q=0;
			for(j=pos;j<=pos+8;j++)
			{
				if(s[j]>='A'&&s[j]<='Z')
				{
					c[q]=s[j]+32;
					q++;
				}
				else
				{
					c[q]=s[j];
					q++;
				}
			}
			p=0;
			if(strncmp(c,st,9)==0)
			{
				for(i=pos;i<=pos+8;i++)
				{
					s[i]=st1[p];
					p++;
				}
			}
		}
	}
	for(i=0;i<n;i++)
	{
		if(s[i]!='$')
		cout<<s[i];
	}
	cout<<endl;
	}
	return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值