数据结构实验之二叉树七:叶子问题
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。
Input
输入数据有多行,每一行是一个长度小于50个字符的字符串。
Output
按从上到下从左到右的顺序输出二叉树的叶子结点。
Sample Input
abd,,eg,,,cf,,,
xnl,,i,,u,,
Sample Output
dfg
uli
Hint
Source
xam
#include <iostream>
#include<queue>
#include<cstdio>
#include<cstdlib>
using namespace std;
typedef struct st
{
char data;
struct st *l,*r;
} tree;
char s[101];
int i;
tree *creat(tree *t)
{
if(s[i]==',')
{
i++;
t=NULL;
}
else
{
t=(tree *)malloc(sizeof(tree));
t->data=s[i++];
t->l=creat(t->l);
t->r=creat(t->r);
}
return t;
}
void leave(tree *root)
{
queue<st *> q; //建队列
q.push(root);
while(! q.empty())
{
root = q.front(); //访问队首元素
q.pop(); //删除队首
if(root)
{
if(root->l== NULL&&root->r== NULL)
{
printf("%c", root->data); //如果是叶子节点则输出
}
q.push(root->l); //左右子树依次入队
q.push(root->r);
}
}
}
int main()
{
while(scanf("%s",s)!=EOF)
{
i=0;
tree *t;
t=creat(t);
leave(t);
printf("\n");
}
return 0;
}