Aizu - ALDS1_4_C Dictionary 散列法搜索

Search III

Your task is to write a program of a simple dictionary which implements the following instructions:

  • insert str: insert a string str in to the dictionary
  • find str: if the distionary contains str, then print 'yes', otherwise print 'no'

Input

In the first line n, the number of instructions is given. In the following n lines, n instructions are given in the above mentioned format.

Output

Print yes or no for each find instruction in a line.

Constraints

  • A string consists of 'A', 'C', 'G', or 'T'
  • 1 ≤ length of a string ≤ 12
  • n ≤ 1000000

Sample Input 1

5
insert A
insert T
insert C
find G
find A

Sample Output 1

no
yes

Sample Input 2

13
insert AAA
insert AAC
insert AGA
insert AGG
insert TTT
find AAA
find CCC
find CCC
insert CCC
find CCC
insert T
find TTT
find T

Sample Output 2

yes
no
no
yes
yes
yes

 代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=1046527;
int n;
char s[15];
char op[15];
char H[maxn][15];
int get (char c)
{
    return c=='A'? 1:(c=='T'?2:(c=='G'?3:4));
}
long long int getKey ()
{
    int sum=0;
   for (int i=0;i<strlen(op);i++)
        sum=sum*5+get(op[i]);
   return sum;
}
//散列函数1
int h1 (long long int sum)
{
    return sum%maxn;
}
//散列函数2
int h2 (long long int sum)
{
    return 1+(sum%(maxn-1));
}
//查找操作
bool finds ()
{
    long long int sum=getKey();
    for (int i=0;;i++)
    {
        int h=(h1(sum)+i*h2(sum))%maxn;
        if(strlen(H[h])==0)
            return false;
        else if(!strcmp(H[h],op))
            return true;
    }
}
//插入操作
void Insert ()
{
    long long int sum=getKey();
    for (int i=0;;i++)
    {
       int h=(h1(sum)+i*h2(sum))%maxn;
        if(strlen(H[h])==0)
       {
         strcpy(H[h],op);
         return ;
       }
        else if(!strcmp(H[h],op))
         return;
    }
}
int main()
{
    scanf("%d",&n);
    while (n--)
    {
       scanf("%s%s",s,op);
       if(s[0]=='i')
       {
           Insert();
       }
       else
       {
           if(finds())
                printf("yes\n");
           else
                printf("no\n");
       }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值