ALDS1_4_C:Dictoinary STL map法

8 篇文章 0 订阅
3 篇文章 0 订阅

ALDS1_4_C:Dictoinary

题目链接:http://judge.u-aizu.ac.jp/onlinejudge/description.jsp?id=ALDS1_4_C

题目如下:

 

Search - Dictionary

Time Limit : 2 sec, Memory Limit : 131072 KB 
 

Search III

Your task is to write a program of a simple dictionary which implements the following instructions:

  • insert str: insert a string str in to the dictionary
  • find str: if the distionary contains str, then print 'yes', otherwise print 'no'

Input

In the first line n, the number of instructions is given. In the following n lines, n instructions are given in the above mentioned format.

Output

Print yes or no for each find instruction in a line.

Constraints

  • A string consists of 'A', 'C', 'G', or 'T'
  • 1 ≤ length of a string ≤ 12
  • n ≤ 1000000

Sample Input 1

5
insert A
insert T
insert C
find G
find A

Sample Output 1

no
yes

Sample Input 2

13
insert AAA
insert AAC
insert AGA
insert AGG
insert TTT
find AAA
find CCC
find CCC
insert CCC
find CCC
insert T
find TTT
find T

Sample Output 2

yes
no
no
yes
yes
yes

Notes

Template in C

 

题目分析:

本题可以使用map来做,定义一个map<char* , bool> T; 的map,其中char*记录键字符串,bool同来表示值true或false。

将输入的字符串存入map,并将这个数据的值改为true。

然后当find时,只需检查这个键key对应的值value是否位true。如果为true,则说明这个单词在字典中;反之则不在字典中。

 

C++代码实现如下:

#include <iostream>
#include <map>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;

int main()
{
    map<char*, bool> T;
    int n;
    cin >> n;
    char str[13], com[13];
    for (int i = 0; i < n; i++)
    {
        cin >> com >> str;
        if (com[0] == 'i')
        {
            T[str] = true;
        }
        else
        {
            if (T[str] == true)
                cout << "yes\n";
            else
                cout << "no\n";
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值