ALDS1_4_A:Linear Search

输入:数量n n个数据 数量q q个不重复的数据

输出:q的数据中和n数据重复的个数

 

Sample Input 1

5
1 2 3 4 5
3
3 4 1

Sample Output 1

3

Sample Input 2

3
3 1 2
1
5

Sample Output 2

0

Sample Input 3

5
1 1 2 2 3
2
1 2

Sample Output 3

2

因为限制条件中q比较小,直接线性搜索

#include <cstdio>
#include <iostream>
#include <vector>
using namespace std;

int main (){
	int n ,q, a,k=0;
	cin>>n;
	vector<int> A;
	for(int i = 0;i<n;i++){
		cin>>a;
		A.push_back(a);
	}
	cin>>q;
	for(int i=0;i<q;i++){
		cin>>a;
		for(int j=0;j<n;j++){
			if(A[j]==a) {k++;break;}
		}
	}
	cout<<k<<endl;;
	return 0;
}

错点:

1.线性搜索时,找到第一个重复的就要break出来,避免后面重复数字又算一次

2.输出最后加换行

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值