HDU 5019 Revenge of GCD gcd+枚举因子

53 篇文章 0 订阅

Problem Description

In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder.
---Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.

 

 

Input

The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers X, Y and K.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= X, Y, K <= 1 000 000 000 000

 

 

Output

For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.

 

 

Sample Input

 

3

2 3 1

2 3 2

8 16 3

 

 

Sample Output

 

1

-1

2

代码及注释如下:

/*
题意:
求两个数a,b公共的从大到小的第k个因子...
先求出a,b的Gcd后枚举求Gcd的因子....
为啥呢...
因为a,b都能整除Gcd,所以a,b肯定能够整除Gcd的因子...
用的优先队列储存因子....
注意数据要用long long int .....
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
using namespace std;
int t;
long long int x,y,k;
priority_queue <long long int>q;
long long int gcd (long long int a,long long int b)
{
    return b? gcd(b,a%b):a;
}
void Clear()
{
    while (!q.empty())
        q.pop();
}
int main()
{
    scanf("%d",&t);
    while (t--)
    {
        Clear();
        scanf("%lld%lld%lld",&x,&y,&k);
        long long int Gcd=gcd(x,y);
        q.push(Gcd);
        if(Gcd!=1)
        {
            q.push(1);
           for (long long int i=2;i*i<=Gcd;i++)
           {
               if(Gcd%i==0)
               {
                   q.push(i);
                   if(i*i!=Gcd)
                   {
                      q.push(Gcd/i);
                   }
               }
           }
        }
        if(q.size()<k)
            printf("-1\n");
        else
        {
            for (int i=0;i<k-1;i++)
                {
                    q.pop();
                }
            printf("%lld\n",q.top());
        }

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值