POJ 1308 Is It A Tree?

N - Is It A Tree?

POJ - 1308

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

这道题和HDU上那道小希的迷宫简直一模一样,用同样的码改了改输出格式就过了。。。

不多bb直接挂码(。。。)

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<cmath>
using namespace std;
int pre[100100];
bool vis[100010];
void init()
{
    for(int i = 0; i <= 100100; i ++)
        pre[i] = i;
    memset(vis, 0, sizeof(vis));
}
int find(int a)
{
    if(a != pre[a])
        pre[a] = find(pre[a]);
    return pre[a];
}
void join(int a, int b)
{
    int i = find(a);
    int j = find(b);
    if(i>j)
    pre[i] = j;
    else pre[j] = i;
}

int main()
{
    int a, b;
    int k = 1;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        int visit = 0;
        if(a==-1 && b==-1)break;
        init();
//        if(find(a) == find(b))visit = 1;
//        join(a, b);
//        vis[a] = vis[b] = 1;

//        while(scanf("%d%d",&a,&b)!=EOF)
//        {
        while(1){
            if(a==0&&b==0)break;
            if(find(a) == find(b))visit = 1;
            join(a, b);
            vis[a] = vis[b] = 1;
            scanf("%d%d",&a,&b);
        }
//        }
        if(visit == 1)printf("Case %d is not a tree.\n",k++);
        else
        {
            int cnt = 0;
            for(int i = 0; i <= 100010; i ++)
                if(vis[i]&&pre[i] == i)
                cnt++;
            if(cnt>1)printf("Case %d is not a tree.\n",k++);
            else printf("Case %d is a tree.\n",k++);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值