PAT (Advanced Level)-1130 Infix Expression

1130 Infix Expression(25 分)

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPGinfix2.JPG
Figure 1Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

思路:根据网上大神的思路 用递归做 string可加性

1.找到根节点  建个bool表 被访问的节点记录一下 没有被访问的的只有根节点

2.结点包含data和左右结点的访问地址 不需要链式存储

3.递归 :

*若一个结点的左右子树值为-1 该结点为叶结点 返回叶结点的本身的值 再往下走到-1尽头 返回空

*递归从根结点开始 根结点 左右子树递归下去 不需要加括号 非根结点要加上括号

因为(a+b)*(c*(-d)) 最外面没有括号
对每一个节点,其值实际上应等于左边子树的运算结果加上本身操作符,再加右边子树的值

若当前结点右子树为空时 说明这个结点的左子树也为空

#include <iostream>
#include <vector>
using namespace std;


struct node
{
	string data;
	int left,right;	
};
vector<node>v;
int root=1;
string dfs(int idx)
{
	if(idx==-1)return "";
	else if(v[idx].right==-1)return v[idx].data;
	return idx==root?dfs(v[idx].left)+v[idx].data+dfs(v[idx].right):"("+dfs(v[idx].left)+v[idx].data+dfs(v[idx].right)+")";
}
int main() 
{
	int n;
	cin>>n;
	vector<bool>visit(n+1,false);
	v.resize(n+1);

	for(int i=1;i<=n;i++)
	{
		cin>>v[i].data>>v[i].left>>v[i].right;
		if(v[i].left!=-1)visit[v[i].left]=true;
		if(v[i].right!=-1)visit[v[i].right]=true;
	}
	while(visit[root]!=false)root++;
	cout<<dfs(root)<<endl;
	
	
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值