hdu1162:Eddy's picture(最小生成树)

http://acm.hdu.edu.cn/showproblem.php?pid=1162

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

 

 

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

 

 

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

 

 

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41

题意分析:

给出n个点,求把这些点连接起来的最小长度。

Prim算法:

#include <stdio.h>
#include <string.h> 
#include <math.h>
#define N 120
double e[N][N], dis[N];
int book[N];
struct data{ 
	double x;
	double y;
}a[N];
int main()
{
	int n, i, j,  u, v, count, inf=99999999;
	double mini, sum;
	while(scanf("%d", &n)!=EOF)
	{
		for(i=1; i<=n; i++)
			for(j=1; j<=n; j++)
				if(i==j)
					e[i][j]=0;
				else
					e[i][j]=inf;
		for(i=1; i<=n; i++)
		{
			scanf("%lf %lf", &a[i].x, &a[i].y);
			for(j=1; j<=n; j++)
				e[i][j]=e[j][i]=sqrt((a[i].x-a[j].x)*(a[i].x-a[j].x) + (a[i].y-a[j].y)*(a[i].y-a[j].y));
		}
		for(i=1; i<=n; i++)
			dis[i]=e[1][i];
		memset(book, 0, sizeof(book));
		book[1]=1;
		sum=0;
		count=1;
		while(count<n)
		{
			mini=inf;
			for(i=1; i<=n; i++)	
			{
				if(book[i]==0 && dis[i]<mini)
				{
					mini=dis[i];
					u=i;
				}
			}
			sum+=dis[u];
			book[u]=1;
			count++;
			for(v=1; v<=n; v++)
				if(!book[v] && e[u][v]<dis[v])
					dis[v]=e[u][v];
		}
		printf("%.2lf\n", sum);	
	}
	return 0;
}

Kruskal算法:

#include <stdio.h>
#include <string.h> 
#include <math.h>
#include <algorithm>
using namespace std;
#define N 120
int f[N];
struct data{ 
	double x;
	double y;
}a[N];
struct cou{
	int u;
	int v;
	double l;
}e[N*N];
int cmp(cou a, cou b)
{
	return a.l<b.l;
}
int getf(int v)
{
	if(f[v]==v)
		return v;
	else
	{
		f[v]=getf(f[v]);
		return f[v];
	}
}
int merge(int u, int v)
{
	int t1, t2;
	t1=getf(u);
	t2=getf(v);
	if(t1!=t2)
	{
		f[t2]=t1;
		return 1;
	}
	return 0;
}
int main()
{
	int n, i, j, t, count, inf=99999999;
	double mini, sum;
	while(scanf("%d", &n)!=EOF)
	{
		count=0;
		for(i=1; i<=n; i++)
		{
			scanf("%lf %lf", &a[i].x, &a[i].y);
			for(j=1; j<i; j++)
			{
				e[count].u=i;
				e[count].v=j;
				e[count].l=sqrt((a[i].x-a[j].x)*(a[i].x-a[j].x) + (a[i].y-a[j].y)*(a[i].y-a[j].y));
				count++;
			}	
		}
		sort(e, e+count, cmp);
		for(i=1; i<=n; i++)
			f[i]=i;
		t=0;
		sum=0;
		for(i=0; i<count; i++)
		{
			if(merge(e[i].u, e[i].v))
			{
				t++;
				sum+=e[i].l;
			}
			if(t==n-1)
				break;
		}
		printf("%.2lf\n", sum);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值