基本概念
深度优先搜索:一直向深处搜索,知道找到解或者走不下去为止。主要运用递归去解决问题。所以一定要注意适时跳出,不然分分钟爆栈。
HDU 2553
在N*N的方格棋盘放置了N个皇后,使得它们不相互攻击(即任意2个皇后不允许处在同一排,同一列,也不允许处在与棋盘边框成45角的斜线上。
你的任务是,对于给定的N,求出有多少种合法的放置方法。
Input
共有若干行,每行一个正整数N≤10,表示棋盘和皇后的数量;如果N=0,表示结束。
Output
共有若干行,每行一个正整数,表示对应输入行的皇后的不同放置数量。
Sample Input
1
8
5
0
Sample Output
1
92
10
Hint
题目选了比较简单的一种情况来问,所以只要一行一行向下搜索就可以了。
#include<stdio.h>
int n,ans,b[11][11];
int check(int x,int y)//判定当前位置能不能放皇后
{
int i,j,y2=y,y1=y;
for(i=x-1;i>=0;i--)
{
if(b[i][y]) return 0;
if(--y1>=0&&b[i][y1]) return 0;
if(++y2<n&&b[i][y2]) return 0;
}
return 1;
}
void dfs(int x)
{
int i;
for(i=0;i<n;i++)
if(check(x,i))
{
if(x==n-1) //n个皇后都放置完毕了,进行记录,然后跳出
{
ans++;
return ;
}
b[x][i]=1;//我个人认为这是dfs核心思想的位置,进行情况记录,然后向后搜索,再将记录消除
dfs(x+1);
b[x][i]=0;
}
}
int main()
{
int i,a[11],j;
for(i=1;i<11;i++)
for(j=0;j<11;j++)
b[i][j]=0;
for(i=1;i<11;i++)
{
n=i;
dfs(0);
a[i]=ans;
ans=0;
}//一共才十种情况,遍历一遍,用数组把结果存下来
int t;
while(~scanf("%d",&t)&&t)
printf("%d\n",a[t]);
return 0;
}
HDU 1016
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
ou are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
Hint
题目大意:顺时针向环里填数,每相邻的两个数的和必须为素数,且第一个空永远填1。那就向下直接搜索就可以了。
#include<stdio.h>
#include<math.h>
using namespace std;
int n,a[21],b[21];
int check(int x)
{
int i;
for(i=2;i<x;i++)//数值比较小,所以没用sqrt做简化
if(x%i==0) return 0;
return 1;
}
void dfs(int x)
{
int i,l;
for(i=1;i<=n;i++)
if(a[i]==0&&check(i+b[x]))
{
a[i]=1;
b[x+1]=i;
if(x==n) return ;
if(x==n-1&&check(i+b[1]))
{
for(l=1;l<n;l++)
printf("%d ",b[l]);
printf("%d",b[l]);//贼坑,句尾多个空格,就不给AC
printf("\n");//记得换行
}
dfs(x+1);
a[i]=0;
}
}
int main()
{
int x,t=1,l;
while(~scanf("%d",&n))
{
for(x=0;x<21;x++)
{
a[x]=0;
b[x]=0;
}
b[1]=1;
a[1]=1;
printf("Case %d:\n",t);
dfs(1);
printf("\n");
t++;
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。