O(1040): Round-number
Description
Most of the time when rounding a given number, it is customary to round to some multiple of a power of 10. However, there is no reason why we cannot use another multiple to do our rounding to. For example, you could round to the nearest multiple of 7, or the nearest multiple of 3.
Given an int n and an int b, round n to the nearest value which is a multiple of b. If n is exactly halfway between two multiples of b, return the larger value.
Input
Each line has two numbers n and b,1<=n<=1000000,2<=b<=500
Output
The answer,a number per line.
Sample Input
5 10 4 10
Sample Output
10 0
换句话说,就和四舍五入差不多。
思路也不难,就是n取余b,判断余数是否大于等于b/2,如果大于就进一位,即取较大的倍数。否则就是取较小的。
#include<iostream>
using namespace std;
int main()
{
int n, b;
while (cin >> n >> b)
{
int x = n % b;
if (x * 2 < b)//因为b有可能是奇数,所以用 if(x < b / 2)判断会WA
{
cout << n - x << endl;
}
else
{
cout << n - x + b << endl;
}
}
return 0;
}