O(1040): Round-number

O(1040): Round-number

Description

    Most of the time when rounding a given number, it is customary to round to some multiple of a power of 10. However, there is no reason why we cannot use another multiple to do our rounding to. For example, you could round to the nearest multiple of 7, or the nearest multiple of 3.
    Given an int n and an int b, round n to the nearest value which is a multiple of b. If n is exactly halfway between two multiples of b, return the larger value.

Input

Each line has two numbers n and b,1<=n<=1000000,2<=b<=500

Output

The answer,a number per line.

Sample Input

5 10
4 10

Sample Output

10
0
题目的大概意思是求和n最接近的并且为b的倍数的数,如果n和b的较小的倍数和较大的倍数同样接近就取较大的。拿题目的例子说吧,和5比较接近的并且是10的倍数有10和0,并且5和10的差值 与 5和0的差值相同,所以取较大的10输出。和4比较接近的也是0和10,由于4更接近于0,所以输出0。
换句话说,就和四舍五入差不多。

思路也不难,就是n取余b,判断余数是否大于等于b/2,如果大于就进一位,即取较大的倍数。否则就是取较小的。

#include<iostream>
using namespace std;
int main()
{
	int n, b;
	while (cin >> n >> b)
	{
		int x = n % b;
		if (x * 2 < b)//因为b有可能是奇数,所以用 if(x < b / 2)判断会WA
		{
			cout << n - x << endl;
		}
		else
		{
			cout << n - x + b << endl;
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值