Round Numbers(数位dp)

Round Numbers(数位dp)

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.

They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input
Line 1: Two space-separated integers, respectively Start and Finish.

Output
Line 1: A single integer that is the count of round numbers in the inclusive range Start…Finish

Sample Input
2 12

Sample Output
6

题意: 找两个数之间有几个数的二进制中0的个数大于等于1的个数

思路: 数位dp,详细见代码

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a,b;
int dp[50][50][50];//dp[k][i][j] k为长度,i为0的个数,j为1的个数
int bit[50];//存二进制
//pos存剩余位数 
//num0存0的个数
//num1存1的个数
//first 1表示出现了1,0表示1还没出现 
//limit 1表示是上边界,0表示不是上边界 
int dfs(int pos,int num0,int num1,int first,int limit)
{//从最高位到最低位 
	if(pos<0)//按位枚举,最低位数是0,那pos==-1说明枚举结束 
	return num0>=num1;//套路,num0>=num1符合题意
	if(!limit&&dp[pos][num0][num1]!=-1)
	return dp[pos][num0][num1];//不是上边界且之前求过值,返回 
	int ans=0;
	int up=limit?bit[pos]:1;//上边界 
	for(int i=0;i<=up;i++)
	{
		if(first==1)//出现1 
		ans+=dfs(pos-1,num0+(i==0),num1+(i==1),first,limit&&(i==up));
		else//有前导0,0不计数 
		ans+=dfs(pos-1,0,i,i,limit&&(i==up));
	}//limit&&i==up 上次是上边界,如果这次也是,那么下次也是
	if(!limit)
	dp[pos][num0][num1]=ans;
	return ans;
}
int solve(int x)
{
	int len=0;
	while(x)
	{
		bit[len++]=x%2;
		x/=2;
	}
/*	for(int i=0;i<len;i++)
	printf("%d",bit[i]) ;
	printf("++\n");*/
	return dfs(len-1,0,0,0,1);
}
int main()
{
	memset(dp,-1,sizeof(dp));
	scanf("%d%d",&a,&b);
	printf("%d\n",solve(b)-solve(a-1));
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值