【快速幂思想求多次幂的前几位数】Leading and Trailing

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

题意:给定n和k,求n的k次幂的前三位数和后三位数

其中后三位数快速幂,前三位数也是快速幂的思想,几乎一模一样

注意最后printf 03%d的意思是三位宽度,不足的用0填充

#include<iostream>
#include<cstdio>
using namespace std;
#define ll long long
ll kpow(ll a,ll b,ll mod){
    ll ans=1;
    while(b){
        if(b&1){
            ans*=a;
            ans%=mod;
        }
        a*=a;
        a%=mod;
        b>>=1;
    }
    return ans;
}
double deal(double x){
    while(x>=1000.0){
        x/=10.0;
    }
    return x;
}
ll prepow(double a,ll b){
    double ans=1.0;
    while(b){
        if(b&1){
            ans*=a;
            ans=deal(ans);
        }
        a*=a;
        a=deal(a);
        b>>=1;
    }
    return ans;
}
int main(){
    int num;
    // std::ios::sync_with_stdio(false);
    cin>>num;
    for(int kk=1;kk<=num;kk++){
        ll a,b;
        cin>>a>>b;
        ll ans1=kpow((ll)a,(ll)b,1000);
        // ll ans1=1;
        ll ans2=prepow((double)a*1.0,(ll)b);
        cout<<"Case "<<kk<<": "<<(ll)ans2<<" ";
        printf("%03d",(int)ans1);
        cout<<endl;
    }
    // int aaa;
    // cin>>aaa;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值