log前三位和快速幂取模求后三位

给定两个整数n和k,要求找到nk的最高三位和最低三位数字。题目提供样例输入和输出,并指出解决方案可以利用log计算最高位,快速幂取模计算最低位。
摘要由CSDN通过智能技术生成

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

这个题,前三位用log写,后三位用快速幂取模写。
快速幂
在这里插入图片描述

快速幂取模模板
在这里插入图片描述

   #include<cstdio>
   #include<cmath>
   int pow_mod(int a,int b)  
 {
        int ans = 1,base=a;// ans:结果;base:底数
        base = base % 1000;
       //【考虑0次方的情况】
        if(b==0)
        {
             return 1%1000;// 任意a的0次幂都是1,故直接用1%c即可 
        } 
          while(b)
    {   
                if(b & 1) // 与运算,判断奇偶性
                ans = (ans*base) % 1000; 
                 b = b >> 1;// 右移一位,相当于除2
                 base = (base * base) % 1000; 
    } 
                return ans;
  } 
        int main()
 {
      int t,a,n,cnt = 1;
      scanf("%d",&t);
      while(t--)
 {
         scanf("%d %d",&a,&n);
         int l,r;
           l=(int)pow( 10.0 , 2 + fmod(n*log10(a) , 1) );   
         while(l > 1000) l /= 10;
          r = pow_mod(a,n);
         printf("Case %d: %d %03d\n",cnt++,l,r);
     }
       return 0;
   }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值