Reachable Numbers

题目描述

 

输入

The first line contains one integer n (1≤ n ≤ 10^9) . 

 

输出

Print one integer: the number of different numbers that are reachable from nn. 

 

样例输入

1098

样例输出

20

提示

多实例测试

 代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>
#include<queue>
#include<math.h>
#include<set>
using namespace std;
#define INF 1e9
typedef long long ll;
#define PI acos(-1)
int a[10];
int main()
{
    ll n,ans;
    while(~scanf("%lld",&n))
    {
        memset(a,0,sizeof(a));
        ans=1;
        if(n <10) printf("9\n");
        else
        {
            while(1)
            {
                n++;
                while(n%10 == 0)
                    n/=10;
                if(n < 10 && a[n] == 1)
                    break;
                else
                {
                    if(n < 10)
                        a[n] = 1;
                    ans++;
                }
            }
            printf("%lld\n",ans);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值