1020 Tree Traversals (25)(25 分)(C++)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题目大意:二叉树的中序后序转层次。

解题思路:我们可以先得出树的先序遍历,再用BFS计算其层次遍历。也可以直接转为层次遍历,具体操作将树看成完全二叉树,那么某节点左孩子的编号为2*index,右孩子的编号为2*index+1。

#include <iostream>
#include <vector>
using namespace std;
std::vector<int> post,in,level(100005,-1);
void traversal(int instart,int inend,int postend,int index){
    if(inend<instart)
        return;
    int i=instart;
    while(i<=inend&&in[i]!=post[postend])
        i++;
    level[index]=post[postend];
    traversal(instart,i-1,postend-(inend-i)-1,2*index);
    traversal(i+1,inend,postend-1,2*index+1);
}
int main(){
    int n;
    scanf("%d",&n);
    post.resize(n);in.resize(n);
    for(int i=0;i<n;i++)
        scanf("%d",&post[i]);
    for(int i=0;i<n;i++)
        scanf("%d",&in[i]);
    traversal(0,n-1,n-1,1);
    cout<<level[1];
    int cnt=1;
    for(int i=2;i<100005;i++){
        if(level[i]!=-1){
            cnt++;
            cout<<' '<<level[i];
        }
        if(cnt==n)
            return 0;
    }
}

方法二:上述方法有点耗空间,所以可以直接存储每一层的节点,按照先左子树后右子树的顺序即可;

#include <iostream>
#include <vector>
using namespace std;
int n;
std::vector<int> post,in,level[30];
void dfs(int postleft,int postright,int inleft,int inright,int index){
    if(postright<postleft)
        return;
    level[index].push_back(post[postright]);   
    int i=inleft;
    while(i<=inright&&in[i]!=post[postright])
        i++;
    dfs(postleft,postleft+i-inleft-1,inleft,i-1,index+1);
    dfs(postleft+i-inleft,postright-1,i+1,inright,index+1);
}
int main(){
    cin>>n;
    post.resize(n);in.resize(n);
    for(int i=0;i<n;i++)
        scanf("%d",&post[i]);
    for(int i=0;i<n;i++)
        scanf("%d",&in[i]);
    dfs(0,n-1,0,n-1,0);
    printf("%d",level[0][0]);
    for(int i=1;i<30;i++)
        for(int j=0;j<level[i].size();j++)
            printf(" %d",level[i][j]);
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值