1043 Is It a Binary Search Tree(25 分)(C++)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

题目大意:给定一个二叉树的先序遍历,判断是否为BST。

解题思路:采用DFS,以左子树小的二叉树为例,假定目前的子树先序遍历为(root,end),根节点肯定为root,那么他的左子树的先序的第一个为root-1,右子树的最后一个节点为end,从root+1开始遍历,得到的第一个大于或者等于root的值的节点即为右子树的第一个节点j,或者从end开始遍历,得到的第一个小于root的值的节点即为左子树最后一个节点i。必然有i-j等于1,如果不满足则说明非BST。

#include <iostream>
#include <vector>
using namespace std;
vector<int>pre(1005),post;
int n, flag = 0;
void posttravel(int preleft, int preright){
	if(preright < preleft)
		return;
	int i = preleft, j = preright;
	if(flag == 0){
		while(++ i <= preright && pre[i] < pre[preleft]) ;
		while(j > preleft && pre[j] >= pre[preleft]) j--;
	}
	else{
		while(++ i <= preright && pre[i] >= pre[preleft]) ;
		while(j > preleft && pre[j] < pre[preleft]) j--;
	}
	if(i - j != 1)
		return;
	posttravel(preleft + 1, i - 1);
	posttravel(i, preright);	
	post.push_back(pre[preleft]);
}
int main(){
	scanf("%d", &n);
	for(int i = 0; i < n; ++ i)
		scanf("%d", &pre[i]);
	posttravel(0, n - 1);
	if(post.size() != n){
		flag = 1;
		post.clear();
		posttravel(0, n -1);
	}
	if(post.size() != n)
		printf("NO");
	else{
		printf("YES\n%d", post[0]);
		for(int i = 1; i < n; ++ i)
			printf(" %d", post[i]);
	}
}

本题也可以用链式做,不过就要遍历至少两遍的树(建树一次,遍历一次)。对建完的树遍历的过程中同时得出后序与先序遍历,当发现先序遍历与原题不符合,立即停止。

#include <iostream>
#include <vector>
using namespace std;
struct node{
	int value;
	node *left, *right;
	node(int x): value(x), left(NULL), right(NULL){};
};
node *insert(node *root, int val){
	if(root == NULL){
		root = new node(val);
		return root;
	}
	if(root->value <= val)
		root->right = insert(root->right, val);
	else
		root->left = insert(root->left, val);
	return root;
}
vector<int>pre, post;
int n, flag = 0, index = 0;
void posttravel(node* root){
	if(root == NULL || root->value != pre[index ++])
		return;
	if(flag == 0){
		posttravel(root->left);
		posttravel(root->right);
		post.push_back(root->value);
	}
	else{
		posttravel(root->right);
		posttravel(root->left);
		post.push_back(root->value);
	}
}
int main(){
	scanf("%d", &n);
	pre.resize(n);
	node* root = NULL;
	for(int i = 0; i < n; ++ i){
		scanf("%d", &pre[i]);
		root = insert(root, pre[i]);
	}
	posttravel(root);
	if(post.size() != n){
		flag = 1; index = 0;
		post.clear();
		posttravel(root);
	}
	if(post.size() != n)
		printf("NO");
	else{
		printf("YES\n%d", post[0]);
		for(int i = 1; i < n; ++ i)
			printf(" %d", post[i]);
	}
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值