1081 Rational Sum(20 分)(C++)

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

考点:最简分数化简

解题思路:要实现两个分数的加法,最重要的是分数的化简,最大公约数的用欧几里得算法,两个分数在相加前,先各自化简,计算完成后再进行化简。相加过程即通分求解。

#include <iostream>
#include <cmath>
using namespace std;
long long int gcd(long long int a, long long int b){
    return b == 0 ? a : gcd(b,a % b);
}
typedef struct 
{
    long long int ing = 0, num = 0,dem = 1;   
}ration;
void simplify(ration &a){
    a.ing += (a.num/a.dem);
    a.num = a.num%a.dem;
    long long int temp = gcd(abs(a.num),a.dem);
    a.num /= temp;
    a.dem /= temp;
}
void add(ration &a, ration b){
    simplify(b);
    a.ing += b.ing;
    a.num = a.num*b.dem + a.dem*b.num;
    a.dem *= b.dem;
    simplify(a);
}
int main(){
    int n;
    ration ans;
    cin>>n;
    for(int i = 0; i < n; i++){
        ration temp;
        scanf("%lld/%lld",&temp.num,&temp.dem);
        add(ans,temp);
    }
    if(ans.ing != 0 || ans.num == 0){
        printf("%lld",ans.ing);
        if(ans.num != 0)
            printf(" ");
    }
    if(ans.num != 0)
        printf("%lld/%lld",abs(ans.num),ans.dem);
}

也可以不用结构体,设几个全局变量

#include <iostream>
using namespace std;
int n;
long long int ansi = 0, ansnum = 0, ansden = 1, tempi, tempnum, tempden;
long long int gcd(long long int a, long long int b){
	return b == 0 ? a : gcd(b, a % b);
} 
void add(){
	ansi += tempi;
	ansnum = ansnum * tempden + ansden * tempnum;
	ansden *= tempden;
}
void simplify(){
	int temp = gcd(ansnum, ansden);
	ansnum /= temp;
	ansden /= temp;
	ansi += (ansnum / ansden);
	ansnum %= ansden;
}
int main(){
	scanf("%d", &n);
	for(int i = 0; i < n; ++ i){
		scanf("%lld/%lld", &tempnum, &tempden);
		tempi = 0;
		add();
		simplify();
	}
	if(ansi != 0 && ansnum != 0)
		printf("%d ", ansi);
	else if(ansnum == 0)
		printf("%d", ansi);
	if(ansnum != 0)
		printf("%d/%d",ansnum, ansden);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值