1111 Online Map(30 分)(C++)

Input our current position and a destination, an online map can recommend several paths. Now your job is to recommend two paths to your user: one is the shortest, and the other is the fastest. It is guaranteed that a path exists for any request.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (2≤N≤500), and M, being the total number of streets intersections on a map, and the number of streets, respectively. Then M lines follow, each describes a street in the format:

V1 V2 one-way length time

where V1 and V2 are the indices (from 0 to N−1) of the two ends of the street; one-way is 1 if the street is one-way from V1 to V2, or 0 if not; length is the length of the street; and time is the time taken to pass the street.

Finally a pair of source and destination is given.

Output Specification:

For each case, first print the shortest path from the source to the destination with distance D in the format:

Distance = D: source -> v1 -> ... -> destination

Then in the next line print the fastest path with total time T:

Time = T: source -> w1 -> ... -> destination

In case the shortest path is not unique, output the fastest one among the shortest paths, which is guaranteed to be unique. In case the fastest path is not unique, output the one that passes through the fewest intersections, which is guaranteed to be unique.

In case the shortest and the fastest paths are identical, print them in one line in the format:

Distance = D; Time = T: source -> u1 -> ... -> destination

Sample Input 1:

10 15
0 1 0 1 1
8 0 0 1 1
4 8 1 1 1
3 4 0 3 2
3 9 1 4 1
0 6 0 1 1
7 5 1 2 1
8 5 1 2 1
2 3 0 2 2
2 1 1 1 1
1 3 0 3 1
1 4 0 1 1
9 7 1 3 1
5 1 0 5 2
6 5 1 1 2
3 5

Sample Output 1:

Distance = 6: 3 -> 4 -> 8 -> 5
Time = 3: 3 -> 1 -> 5

Sample Input 2:

7 9
0 4 1 1 1
1 6 1 1 3
2 6 1 1 1
2 5 1 2 2
3 0 0 1 1
3 1 1 1 3
3 2 1 1 2
4 5 0 2 2
6 5 1 1 2
3 5

最短路径问题。

但是本题中要求两种最短路径,也就是用两次Dijkstra,其中求最短路径时,在Dijkstra进行时,就可以顺带求出最短路径中时间也最短的那一条,但是求最快路径时,最后必须用DFS得到节点数最少的那一条路径

#include <iostream>
#include <vector>
using namespace std;
const int inf = 999999999;
int n, m, s, des, ansdis1, tempcnt = 0, cnt = inf;
bool visit[505];
int elength[505][505],etime[505][505],dis[505],t[505],pre[505];
std::vector<int> temppath,prepos[505],anspath1,anspath2;
void dfs(int index){
    if(index == s){
        if(tempcnt < cnt){
        	anspath2 = temppath;
        	cnt = tempcnt;
		}
            
        return;
    }
    tempcnt++;
    temppath.push_back(index);
    for(int i = 0; i < prepos[index].size(); i++)
        dfs(prepos[index][i]);
    temppath.pop_back();
    tempcnt--;
}
int main(){
    cin>>n>>m;
    fill(elength[0],elength[0]+505*505,inf);
    fill(dis,dis+505,inf);
    fill(t,t+505,inf);
    for(int i = 0; i < m; i++){
        int a,b,flag,tempd,tempt;
        scanf("%d %d %d %d %d",&a,&b,&flag,&tempd,&tempt);
        elength[a][b] = tempd;
        etime[a][b] = tempt;
        if(flag == 0){
            elength[b][a] = tempd;
            etime[b][a] = tempt;
        }
    }
    cin>>s>>des;
    dis[s] = 0;
    t[s] = 0;
    for(int i = 0; i < n; i++){
        int u = -1,minn = inf;
        for(int j = 0; j < n; j++){
            if(dis[j] < minn && visit[j] == false){
                u = j;
                minn = dis[j];
            }
        }
        if(u == -1)
            break;
        visit[u] = true;
        for(int v = 0; v < n; v++){
            if(visit[v] == false && elength[u][v] < inf){
                if(dis[u] + elength[u][v] < dis[v]){
                    dis[v] = dis[u] + elength[u][v];
                    t[v] = t[u] + etime[u][v];
                    pre[v] = u;
                }
                else if(dis[u] + elength[u][v] == dis[v] && t[u] + etime[u][v] < t[v]){
                    t[v] = t[u] + etime[u][v];
                    pre[v] = u;
                }
            }
        }
    }
    ansdis1 = dis[des];
    int temp = des;
    while(temp != s){
        anspath1.push_back(temp);
        temp = pre[temp];
    }
    fill(visit,visit+505,false);
    fill(t,t+505,inf);
    t[s] = 0;
    for(int i = 0; i < n; i++){
        int u = -1,minn = inf;
        for(int j = 0; j < n; j++){
            if(t[j] < minn && visit[j] == false){
                u = j;
                minn = t[j];
            }
        }
        if(u == -1)
            break;
        visit[u] = true;
        for(int v = 0; v < n; v++){
            if(visit[v] == false && elength[u][v] < inf){
                if(t[u] + etime[u][v] < t[v]){
                    t[v] = t[u] + etime[u][v];
                    prepos[v].clear();
                    prepos[v].push_back(u);
                }
                else if(t[u] + etime[u][v] == t[v])
                    prepos[v].push_back(u);
            }
        }
    }
    dfs(des);
    if(anspath2 == anspath1)
        printf("Distance = %d; Time = %d: %d",ansdis1,t[des],s);
    else{
        printf("Distance = %d: %d",ansdis1,s);
        for(int i = anspath1.size() - 1; i >= 0; --i)
            printf(" -> %d",anspath1[i]);
        printf("\nTime = %d: %d",t[des],s);
    }
    for(int i = anspath2.size() - 1; i >= 0; --i)
        printf(" -> %d",anspath2[i]);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值