1134 Vertex Cover(25 分)(C++)

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

图论:给定一个图,再给定一个节点集合,判断这些节点能否包含所有的边。

方法一:存储所有边的两个端点,hash记录访问了哪些端点,每次记录完端点后,对所有的边遍历,当有一个边的两个端点均没有访问过,则不是。

#include <iostream>
#include <vector>
using namespace std;
int main(){
	int n, m, k, cnt, temp;
	scanf("%d %d", &n, &m);
	vector<pair<int, int>>edge(m);
	for(int i = 0; i < m; ++ i)
		scanf("%d %d", &edge[i].first, &edge[i].second);
	scanf("%d", &k);
	for(int i = 0; i < k; ++ i){
		scanf("%d", &cnt);
		vector<int>visit(n, false);
		bool flag = true;
		for(int j = 0; j < cnt; ++ j){
			scanf("%d", &temp);
			visit[temp] = true;
		}
		for(int j = 0; j < m; ++ j)
			if(visit[edge[j].first] == false && visit[edge[j].second] == false){
				flag = false;
				break;
			}
		printf("%s\n", flag == true ? "Yes" : "No");
	}
}

方法二:用常规处理图的方法,二维数组记录每条边,若访问到,则标记一下,不过这种方法用大数组会段错误,用vector创建二维数组

#include <iostream>
#include <vector>
using namespace std;
int n, m, k, cnt;
int main(){
	scanf("%d %d", &n, &m);
	vector<int>v[n + 1];
	for(int i = 0; i < m; ++ i){
		int a, b;
		scanf("%d %d", &a, &b);
		v[a].push_back(b);
		v[b].push_back(a);
	}
	scanf("%d", &k);
	for(int i = 0; i < k; ++ i){
		scanf("%d", &cnt);
		int num = 0, temp;
		vector<vector<bool>>visit(n, vector<bool>(n, false));
		for(int j = 0; j < cnt; ++ j){
			scanf("%d", &temp);
			for(int u = 0; u < v[temp].size(); ++ u)
				if(visit[temp][v[temp][u]] == false){
					visit[temp][v[temp][u]] = visit[v[temp][u]][temp] = true;
					++ num;
				}
		}
		printf("%s\n", num == m ? "Yes" : "No");
	}
}

方法三:在方法二的基础上进行优化,用序号存储边,则空间复杂度,从n^2下降到n

#include <iostream>
#include <vector>
using namespace std;
int n, m, k, cnt;
int main(){
	scanf("%d %d", &n, &m);
	vector<int>v[n + 1];
	for(int i = 0; i < m; ++ i){
		int a, b;
		scanf("%d %d", &a, &b);
		v[a].push_back(i);
		v[b].push_back(i);
	}
	scanf("%d", &k);
	for(int i = 0; i < k; ++ i){
		scanf("%d", &cnt);
		int num = 0, temp;
		vector<bool>visit(m,false);
		for(int j = 0; j < cnt; ++ j){
			scanf("%d", &temp);
			for(int u = 0; u < v[temp].size(); ++ u)
				if(visit[v[temp][u]] == false){
					visit[v[temp][u]] = true;
					++ num;
				}
		}
		printf("%s\n", num == m ? "Yes" : "No");
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值