1135 Is It A Red-Black Tree (30 分)(C++)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpgrbf2.jpgrbf3.jpg
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

解题思路:题目给出了红黑树的5个性质,要判断是否为红黑树,主要要用到2,4,5三个性质

建树:本题给出的是先序遍历,只要按照BST的建树原则插入节点即可建树

性质2:建树后直接判断根节点的value值

性质4:建树后,对树的每个值为负节点判断其子女节点是否存在,存在的话是否为正。

性质5:性质5的意思是,对每个节点来讲,到达其下的每个叶子节点,所经历的黑色节点的个数一样多,即每个节点的左右节点的“黑高”一致。

#include <iostream>
#include <cmath>
using namespace std;
struct node{
	int val;
	node *left, *right;
	node(int x) : val(x), left(nullptr), right(nullptr){};
};
node *insert(node *root, int value){
	if(root == nullptr)
		root = new node(value);
	else if(abs(root->val) >= abs(value))
		root->left = insert(root->left, value);
	else
		root->right = insert(root->right, value);
	return root;
}
int getBlackHeight(node *root){
	if(root == nullptr)
		return 1;
	return max(getBlackHeight(root->right), getBlackHeight(root->left)) + (root->val > 0 ? 1 : 0);
}
bool judge(node *root){
	if(root == nullptr)
		return true;
	else if(root->val > 0 || (root->val < 0 && (root->left == nullptr || root->left->val > 0) && (root->right == nullptr || root->right->val > 0)))
		return (getBlackHeight(root->left) == getBlackHeight(root->right)) && judge(root->left) && judge(root->right);
	else
		return false;
}
int n, k, temp;
int main(){
	scanf("%d", &n);
	for(int i = 0; i < n; ++ i){
		node *root = nullptr;
		scanf("%d", &k);
		for(int j = 0; j < k; ++ j){
			scanf("%d", &temp);
			root = insert(root, temp);
		}
		bool flag = (root->val > 0 && judge(root));
		printf("%s\n", flag == true ? "Yes" : "No");
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值