a-矩阵快速幂

Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and i4i4. Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right. 

Input

The first line of input contains an integer t, the number of test cases. t test cases follow. 
 Each case contains only one line with three numbers N, a and b where N,a,b < 231231 as described above. 

Output

For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.

Sample Input

2
3 1 2
4 1 10

Sample Output

85
369

Hint

In the first case, the third number is 85 = 2*1十2十3^4.
 In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.




题意:F(i)=F(i-2)+F(i-1)+i^4,求f(n)
首先我们需要知道

(i+1)^4 =  1 * i^4 +4 * i^3 + 6 * i^2 +4 * i + 1

(i+1)^3=   * i^3 +3 * i^2+ 3 * i +1;

(i+1)^2=   * i^2 +2 * i +1;

(i+1)    =   * i + 1;

我构造的矩阵
        

注意还要特判一下n=1和2的时候

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
typedef long long ll;
const ll mod=2147493647;
const int maxn=7;
using namespace std;
struct mat{
	ll m[maxn][maxn];
}unit;
mat operator *(mat a,mat b){
    mat ret;
    ll x;
    for(int i=0;i<maxn;i++){
        for(int j=0;j<maxn;j++){
            x=0;
            for(int k=0;k<maxn;k++){
                x+=1ll*a.m[i][k]*b.m[k][j]%mod;
            ret.m[i][j]=x%mod;
            }
        }
    }return ret;
}
void init_unit()
{
    for(int i=0;i<maxn;i++)
        unit.m[i][i]=1;
    return ;
}
mat pow_mat(mat a,ll n){
    mat ret =unit;
    while(n){
        if(n&1)ret =ret*a;
        a=a*a;
        n>>=1;
    }
    return ret;
}

int main()
{
	int t;
	scanf("%d",&t);
	mat c;
	for(int i=0;i<maxn;i++)
		for(int j=0;j<maxn;j++)
			c.m[i][j]=0;
	c.m[0][1]=1;
	c.m[1][0]=2;c.m[1][1]=c.m[1][2]=1;
	c.m[2][2]=1;c.m[2][3]=4;c.m[2][4]=6;c.m[2][5]=4;c.m[2][6]=1;
	c.m[3][3]=1;c.m[3][4]=c.m[3][5]=3;c.m[3][6]=1;
	c.m[4][4]=1;c.m[4][5]=2;c.m[4][6]=1;
	c.m[5][5]=c.m[5][6]=1;
	c.m[6][6]=1;
	init_unit();
	while(t--){
		ll n;
		ll a;ll b;
		scanf("%lld%lld%lld",&n,&a,&b);
		mat ans; 
		ans=pow_mat(c,n-2);
		ll p;
		/*for(int i=0;i<maxn;i++){
			for(int j=0;j<maxn;j++){
				printf("%lld   "  ,ans.m[i][j]);
			}
			cout<<endl; 
		}*/
		if(n==1)p=a;
		else if(n==2) p=b;
		else
		p=(1ll*a*ans.m[1][0]%mod+1ll*b*ans.m[1][1]%mod+1ll*81*ans.m[1][2]%mod + 27ll*ans.m[1][3] + 9ll*ans.m[1][4] + 3ll*ans.m[1][5] + ans.m[1][6])%mod;
		printf("%lld\n",p);
	}
	return 0;
}
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 4
    评论
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

谷丘-CODER

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值