PAT Judge (25分--题意和测试点详细讲解)

39 篇文章 4 订阅

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10
​4
​​ ), the total number of users, K (≤5), the total number of problems, and M (≤10
​5
​​ ), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:
For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

先来说一下每个测试点的测试内容
在这里插入图片描述
题意简单,就是排序问题,但需要注意的细节很多。
题意大概是:n个队伍m个题目,每个队伍的每个题目有3种状态:
(1) 都没提交—— 不计入排名
(2) 有提交但都没通过编译——不计入排名
(3) 其余计入排名(包括编译通过提交的零分的)
对队伍排名,要求:
(1) 总分最高则排在前面,相同分数提交满分的题目越多排在前面,前两者都相同队伍id小的排在前面
直接做就可以了,我们可以只存必然出现在排名上的队伍,也可以把出现与否也写进cmp函数里面,最后排序的时候,一定出现在排名上的队伍排在前面。本质就是cmp函数怎么写而已。
输出注意: 没有提交的题目输出"-", 提交过的题目,编译没成功也输出0分,编译成功直接输出分数——也可能是0分。

#include<iostream>
#include<algorithm>
using namespace std;
int v[10];
struct student{
	int ID;
	int score[6];
	int ans;//总分 
	int flag; //输出标记 1为输出 
	int AC; // 满分的题目个数 
}p[10005];
bool cmp(student a,student b){
	if(a.ans!=b.ans)
	return a.ans>b.ans;
	else if(a.AC!=b.AC)
	return a.AC>b.AC;
	else
	return a.ID<b.ID;
}
int main ()
{
	int n,k,m;
	scanf("%d %d %d",&n,&k,&m);
    for(int i=1;i<=k;i++){
    	scanf("%d",&v[i]);
	}
	for(int i=1;i<=n;i++){
		p[i].ID=i;//这些赋初值起初没加一直对后一个测试点一直没过(我还一直以为自己少思考了哪种情况)
		p[i].flag=0;
		p[i].ans=p[i].AC=0;
		for(int j=1;j<=k;j++){
			p[i].score[j]=-1;//-1代表没提交
		}
	}
	for(int i=0;i<m;i++){
		int a,b,c;
		scanf("%d %d %d",&a,&b,&c);
		p[a].ID=a;
		if(c>=0)
			p[a].flag=1;
		else {
			if(p[a].score[b]==-1)
			p[a].score[b]=0;
		}
		if(p[a].score[b]<c){
			p[a].score[b]=c;
		}	
	}
	for(int i=1;i<=n;i++){
		if(p[i].flag){
			for(int j=1;j<=k;j++){
			if(p[i].score[j]>=0)
			p[i].ans+=p[i].score[j];
			if(p[i].score[j]==v[j])
			p[i].AC++;
		  }
		}
	}
	sort(p+1,p+n+1,cmp);
	int v=0,x=0x3f3f3f3f;
	for(int i=1;i<=n;i++){
		if(p[i].flag){
			if(p[i].ans==x){
				x=p[i].ans;
				printf("%d %05d %d",v,p[i].ID,p[i].ans);
			}
			else{
				v=i;
				x=p[i].ans;
			    printf("%d %05d %d",i,p[i].ID,p[i].ans);	
			}
			
			for(int j=1;j<=k;j++){
				if(p[i].score[j]==-1)
				printf(" -");
				else
				printf(" %d",p[i].score[j]);
			}
			printf("\n");
		}
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值