USACO Section1.2 Your Ride is Here 翻译&解题报告

YOUR RIDE IS HERE 

It is a well-known fact that behind every good comet is a UFO. These UFOs often come to collect loyal supporters from here on Earth. Unfortunately, they only have room to pick up one group of followers on each trip. They do, however, let the groups know ahead of time which will be picked up for each comet by a clever scheme: they pick a name for the comet which, along with the name of the group, can be used to determine if it is a particular group's turn to go (who do you think names the comets?). The details of the matching scheme are given below; your job is to write a program which takes the names of a group and a comet and then determines whether the group should go with the UFO behind that comet.

Both the name of the group and the name of the comet are converted into a number in the following manner: the final number is just the product of all the letters in the name, where "A" is 1 and "Z" is 26. For instance, the group "USACO" would be 21 * 19 * 1 * 3 * 15 = 17955. If the group's number mod 47 is the same as the comet's number mod 47, then you need to tell the group to get ready! (Remember that "a mod b" is the remainder left over after dividing a by b; 34 mod 10 is 4.)

Write a program which reads in the name of the comet and the name of the group and figures out whether according to the above scheme the names are a match, printing "GO" if they match and "STAY" if not. The names of the groups and the comets will be a string of capital letters with no spaces or punctuation, up to 6 characters long.

一个众所周知的事实,在每一彗星后面是一个不明飞行物 UFO. 这些不明飞行物时常来收集来自在 地球上忠诚的支持者. 不幸地,他们的空间在每次旅行只能带上一群支持者. 他们要做的是用一种 聪明的方案让每一个团体人被彗星带走. 他们为每个彗星起了一个名字,通过这些名字来决定一个 团体是不是特定的彗星带走. 那个相配方案的细节在下面被给出; 你的工作要写一个程序来通过团体的名字和彗星的名字来决定一个组是否应该与在那一颗彗星后 面的不明飞行物搭配. 团体的名字和彗星的名字都以下列各项方式转换成一个数字: 这个后的数字代表名字中所有字 母的信息,"A" 是 1 和 "Z" 是 26. 举例来说,团体 "USACO" 会是 21*19*1*3*15=17955 . 如果团体的数字 mod 47 等于彗星的数字 mod 47,那么你要告诉这个团体准备好被带走! 写一个程序读入彗星的名字和团体的名字,如果搭配打印"GO"否者打印"STAY"  团体的名字和彗星的名字将会是没有空格或标点的一串大写字母(不超过 6 个字母)

Examples:

InputOutput
COMETQ
HVNGAT
GO
ABSTAR
USACO 
STAY

PROGRAM NAME: ride

This means that you fill in your header with:
PROG: ride  
WARNING:  You must have 'ride' in this field or the wrong test data (or no test data) will be used.

INPUT FORMAT

Line 1:An upper case character string of length 1..6 that is the name of the comet.
Line 2:An upper case character string of length 1..6 that is the name of the group.

NOTE: The input file has a newline at the end of each line but does not have a "return". Sometimes, programmers code for the Windows paradigm of "return" followed by "newline"; don't do that! Use simple input routines like "readln" (for Pascal) and, for C/C++, "fscanf" and "fid>>string".

NOTE 2: Because of the extra characters, be sure to leave enough room for a 'newline' (also notated as '\n') and an end of string character ('\0') if your language uses it (as C and C++ do). This means you need eight characters of room instead of six.

SAMPLE INPUT (file ride.in)

COMETQ
HVNGAT

OUTPUT FORMAT

A single line containing either the word "GO" or the word "STAY".

SAMPLE OUTPUT (file ride.out)

GO

OUTPUT EXPLANATION

Converting the letters to numbers:
COMETQ 
3151352017 
HVNGAT
822147120 
then calculate the product mod 47:
3 * 15 * 13 * 5 * 20 * 17 = 994500 mod 47 = 27
8 * 22 * 14 * 7 *  1 * 20 = 344960 mod 47 = 27

Because both products evaluate to 27 (when modded by 47), the mission is 'GO'. 


ANALYSIS:

This is probably the easiest problem in the entire set of lessons. An `ad hoc' problem, no particular algorithms or tricks are needed save one: one must be careful to get the input without processing the newline on the end!

这可能是整套课程中最简单的问题。一个'特设'问题,不需要特别的算法或技巧,除了一个:一个必须小心得到输入,而不处理换行符!

代码如下(C):

/*
ID: zhaoxia13
LANG: C
TASK: ride
*/

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

int main()
{
	int a1 = 1, b1 = 1, i, l1, l2;
	char a[1000], b[1000];
	freopen("ride.in","r",stdin);
	freopen("ride.out","w",stdout);
	scanf("%s%s", a, b);
	l1 = strlen(a);
	l2 = strlen(b);
	for(i = 0; i < l1; i++)
		a1 *= a[i]-64;
	for(i = 0; i < l2; i++)
		b1 *= b[i]-64;
	if(a1%47 == b1%47)
		printf("GO\n");
	else 
		printf("STAY\n");
	fclose(stdin);
	fclose(stdout);
	return 0;
}

和国内OJ不同,USACO 全部都是要交文件交文件交文件!还要在代码前面加注释!(泪


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值