Section 1.1 PROB Your Ride Is Here

题目原文

Section 1.1的题目非常基础,基本上就是让你熟悉一下这个平台的提交规则而已。本题是section1.1的第一题,下面是题目原文:

Your Ride Is Here

It is a well-known fact that behind every good comet is a UFO. These UFOs often come to collect loyal supporters from here on Earth. Unfortunately, they only have room to pick up one group of followers on each trip. They do, however, let the groups know ahead of time which will be picked up for each comet by a clever scheme: they pick a name for the comet which, along with the name of the group, can be used to determine if it is a particular group's turn to go (who do you think names the comets?). The details of the matching scheme are given below; your job is to write a program which takes the names of a group and a comet and then determines whether the group should go with the UFO behind that comet.

Both the name of the group and the name of the comet are converted into a number in the following manner: the final number is just the product of all the letters in the name, where "A" is 1 and "Z" is 26. For instance, the group "USACO" would be 21 * 19 * 1 * 3 * 15 = 17955. If the group's number mod 47 is the same as the comet's number mod 47, then you need to tell the group to get ready! (Remember that "a mod b" is the remainder left over after dividing a by b; 34 mod 10 is 4.)

Write a program which reads in the name of the comet and the name of the group and figures out whether according to the above scheme the names are a match, printing "GO" if they match and "STAY" if not. The names of the groups and the comets will be a string of capital letters with no spaces or punctuation, up to 6 characters long.

Examples:

InputOutput
COMETQ
HVNGAT
GO
ABSTAR
USACO 
STAY

PROGRAM NAME: ride

This means that you fill in your header with:
PROG: ride

INPUT FORMAT

Line 1:An upper case character string of length 1..6 that is the name of the comet.
Line 2:An upper case character string of length 1..6 that is the name of the group.

NOTE: The input file has a newline at the end of each line but does not have a "return". Sometimes, programmers code for the Windows paradigm of "return" followed by "newline"; don't do that! Use simple input routines like "readln" (for Pascal) and, for C/C++, "fscanf" and "fid>>string".

SAMPLE INPUT (file ride.in)

COMETQ
HVNGAT

OUTPUT FORMAT

A single line containing either the word "GO" or the word "STAY".

SAMPLE OUTPUT (file ride.out)

GO

分析

这个题目简单来说就是输入两行长度在1到6之间的大写英文字符串,把两行每个字符对应的26个字母顺序数字累乘,例如USACO的话就是21 * 19 * 1 * 3 * 15 = 17955,如果得到的两个结果对47取余相等,就输出GO,否则输出STAY。


本题的关键在于把字符char转换成int做累乘运算,最方便的方法是使用char字符相减直接得到对应的int值:

char ca = 'B';
int  ia = ca - 'A' + 1


本题代码如下:

/*
ID: your_id_here
LANG: C++
TASK: ride
*/
#include <fstream>
#include <string>

using namespace std;

int getProduct(string in)
{
	int out = 1;
	for (int i = 0; i < in.length(); ++i)
	{
		out *= (in[i] - 'A' + 1);
	}
	return out;
}


int main()
{
	ifstream fin("ride.in");
	ofstream fout("ride.out");

	string group;
	string comet;
	fin >> comet >> group ;

	if(getProduct(comet)%47 == getProduct(group)%47)
		fout << "GO" << endl;
	else
		fout << "STAY" << endl;

	return 0;
}



提交结果:

TASK: ride
LANG: C++

Compiling...
Compile: OK

Executing...
   Test 1: TEST OK [0.000 secs, 3492 KB]
   Test 2: TEST OK [0.000 secs, 3492 KB]
   Test 3: TEST OK [0.000 secs, 3492 KB]
   Test 4: TEST OK [0.000 secs, 3492 KB]
   Test 5: TEST OK [0.000 secs, 3492 KB]
   Test 6: TEST OK [0.003 secs, 3492 KB]
   Test 7: TEST OK [0.003 secs, 3492 KB]
   Test 8: TEST OK [0.005 secs, 3492 KB]
   Test 9: TEST OK [0.005 secs, 3492 KB]
   Test 10: TEST OK [0.005 secs, 3492 KB]

All tests OK.

官方给出的参考答案:

#include <stdio.h>
#include <ctype.h>

int
hash(char *s)
{
	int i, h;

	h = 1;
	for(i=0; s[i] && isalpha(s[i]); i++)
		h = ((s[i]-'A'+1)*h) % 47;
	return h;
}

void
main(void)
{
	FILE *in, *out;
	char comet[100], group[100];  /* bigger than necessary, room for newline */

	in = fopen("input.txt", "r");
	out = fopen("output.txt", "w");

	fgets(comet, sizeof comet, in);
	fgets(group, sizeof group, in);

	if(hash(comet) == hash(group))
		fprintf(out, "GO\n");
	else
		fprintf(out, "STAY\n");
	exit (0);
}


 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值