1113 Integer Set Partition(小模拟)(简单逻辑)

1113 Integer Set Partition (25 分)

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A​1​​ and A​2​​ of n​1​​ and n​2​​ numbers, respectively. Let S​1​​ and S​2​​ denote the sums of all the numbers in A​1​​ and A​2​​, respectively. You are supposed to make the partition so that ∣n​1​​−n​2​​∣ is minimized first, and then ∣S​1​​−S​2​​∣ is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10​5​​), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2​31​​.

Output Specification:

For each case, print in a line two numbers: ∣n​1​​−n​2​​∣ and ∣S​1​​−S​2​​∣, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

/**
本题题意:
    题意就是给定n个数, 现在要将n个数分成2堆
    首先 要使每堆的个数差最小, 然后要使每堆的和差最大
本题思路:
    首先将n个数 按从小到大排序,  然后将数字分隔成1 : 1(这样差就最小)
    当n为奇数时, 将中间数 归到已经完成排序的数字右边, 这样和差最大
**/

#include<iostream>
#include<algorithm>
using namespace std;
const int maxsize = 1e5 + 5;
int a[maxsize];
int main(){
	int n;
	scanf("%d", &n);
	for(int i = 0; i < n; i++){
		scanf("%d", &a[i]);
	}
	int mid = (n - 1) / 2;
	sort(a, a + n);
	int a1 = 0, a2 = 0;
	for(int i = 0; i < n; i++){
		if(n % 2 == 0){
			if(i <= mid)
				a1 += a[i];
			else
				a2 += a[i];
		}else{
			if(i < mid)
				a1 += a[i];
			else
				a2 += a[i];
		}
	}
	printf("%d %d\n", 2 * (mid + 1) - n, a2 - a1);
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值