2017 ICPC Mid-Central USA Region- Honey Heist(BFS)

5092: Honey Heist

题目描述
0x67 is a scout ant searching for food and discovers a beehive nearby. As it approaches the honeycomb,0x67 can sense an area inside packed with dried honey that can be easily carried back to the nest and stored for winter. However, it must burrow through the honeycomb to reach the cell containing the sweet loot. If 0x67 can create a passage to the honey to help the other ants find it, it will do so before returning to the nest. The cells of the honeycomb are numbered in row major order, so cell IDs can be assigned as shown below:

When 0x67 discovers the opening to the honeycomb, it enters the cell. Some ants are stronger than others, depending on their age, so 0x67 can only chew through at most N cells before its jaw wears out and must return to the nest to recuperate. The honeycomb is hexagonal, and each edge length is R cells. 0x67 enters through a hole at location A and must get to the honey at location B by chewing a path through no more than N adjacent cells. Because ants can be competitive, 0x67 wants to reach the honey by chewing through the fewest possible cells. 0x67 can also sense some of the cells are hardened with wax and impossible to penetrate, so it will have to chew around those to reach the cell at location B.

Scout ants have rudimentary computational skills, and before 0x67 begins to chew, it will work out where it needs to go, and compute K, the least number of cells it needs to chew through to get from A to B, where B is the Kth cell. If K > N, 0x67 will not be strong enough to make the tunnel. When 0x67 returns to the nest, it will communicate to its nestmates how many cells it chewed through to get to B, or will report that it could not get to the honey.

输入
The input contains two lines. The first line contains five blank separated integers: R N A B X
R: the length (number of cells) of each edge of the grid, where 2 ≤ R ≤ 20. The total number of cells in the grid can be determined by taking a difference of cubes, R3 − (R − 1)3.

N: the maximum number of cells 0x67 can chew through, where 1 ≤ N < R3 − (R − 1)3.
A: the starting cell ID, This cell is located on one of the grid edges: The cell has fewer than six neighbors.
B: the cell ID of the cell containing the honey, where 1 ≤ B ≤ R3 − (R − 1)3.
X: the number of wax-hardened cells, where 0 ≤ X < (R3 − (R − 1)3) − 1.
The second line contains X integers separated by spaces, where each integer is the ID of a wax-hardened cell.
The ID’s, A, B, and all the ID’s on the second line, are distinct positive integers less than or equal to R3 − (R − 1)3.

输出
A single integer K if 0x67 reached the honey at cell B, where B is the Kth cell, otherwise the string No if it was impossible to reach the honey by chewing through N cells or less.

样例输入
6 6 1 45 11
15 16 17 19 26 27 52 53 58 65 74
样例输出
6

在这里插入图片描述

题意:有一个蜂巢,排列方式如上图,r代表六边形的边长,蚂蚁从a点走到b点,最多步数是n,有x个障碍点,如果蚂蚁可以走到b点输出最短步数,走不到则输出no

思路:处理这个无向图的边比较麻烦,先用vector存图,用链式前向星存边,跑一边bfs

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
#include<algorithm>
#include <map> m
using namespace std;
#define memset(a,b) memset(a,b,sizeof(a))
#define ll long long
#define inf 0x3f3f3f3f
const int maxn=1e5+10;

int vis[maxn];        
int vv[maxn];      
int r,a,b,n,x;
vector <int> v[50];        
int head[maxn];
int cnt=1;
struct node{
    int next,to;
}edge[maxn*2];
struct nod{
    int pos,step;
};

void add(int a,int b)
{
    edge[cnt].next=head[a];
    edge[cnt].to=b;
    head[a]=cnt;
    cnt++;
}
int main()
{
    int d,z,num=1;
    memset(head,-1);
    scanf("%d %d %d %d %d",&r,&n,&a,&b,&x);
    for(int i=1;i<=x;i++){
        scanf("%d",&z);
        vis[z] = 1;
    }

    d=r;
    for(int i=1;i<=r;i++){
        for(int j=0;j<d;j++)
          v[i].push_back(num),num++;
        d++;
    }
    d-=2;
    for(int i=r+1;i<=2*r-1;i++){
        for(int j=0;j<d;j++)
            v[i].push_back(num),num++;
        d--;
    }

//    for(int i=1;i<=2*r-1;i++){
//        for(int j=0;j<v[i].size();j++)
//            cout<<v[i][j]<<" ";
//        cout<<endl;
//    }

    int x,y;
    for(int i=1;i<r;i++){
        for(int j=0;j<v[i].size();j++){
            x=i-1,y=j;
            if(x>0 && y<v[x].size())
                add(v[i][j],v[x][y]);
            y = j-1;
            if(x > 0 && y>=0)
                add(v[i][j],v[x][y]);

            x = i+1,y=j;
            add(v[i][j],v[x][y]);
            y = j+1;
            add(v[i][j],v[x][y]);

            x = i,y=j-1;
            if(y >= 0)
                add(v[i][j],v[x][y]);
            y =j+1;
            if(y<v[x].size())
                add(v[i][j],v[x][y]);
        }
    }

    for(int j=0;j<v[r].size();j++){
            x=r-1,y=j;
            if(x>0)
                add(v[r][j],v[x][y]);
            y = j-1;
            if(x > 0 && y>=0)
                add(v[r][j],v[x][y]);

            x = r+1,y=j-1;
            if(y >= 0)
              add(v[r][j],v[x][y]);
            y = j;
            if(y < v[x].size())
              add(v[r][j],v[x][y]);

            x = r,y=j-1;
            if(y >= 0)
                add(v[r][j],v[x][y]);
            y =j+1;
            if(y<v[r].size())
                add(v[r][j],v[x][y]);
    }


     for(int i=r+1;i<=2*r-1;i++){
        for(int j=0;j<v[i].size();j++){
            x=i-1,y=j;
            add(v[i][j],v[x][y]);
            y = j+1;
            if(y<v[x].size())
                add(v[i][j],v[x][y]);

            x = i+1,y=j;
            if(x <= 2*r-1)
              add(v[i][j],v[x][y]);
            y = j-1;
            if(x<=2*r-1 && y>=0)
              add(v[i][j],v[x][y]);

            x = i,y=j-1;
            if(y >= 0)
                add(v[i][j],v[x][y]);
            y =j+1;
            if(y<v[x].size())
                add(v[i][j],v[x][y]);
        }
    }


//    for(int i=head[16];~i;i=edge[i].next){
//        cout<<edge[i].to<<endl;
//    }

    int kk,flag=0;
    queue <nod> q;
    q.push(nod{a,0});
    nod e;
    while(q.size()>0){
        e = q.front();
       // cout<<"点:"<<e.pos<<"步数:"<<e.step<<endl;
        if(e.pos == b && e.step <= n){
            flag =1;
            kk = e.step;
            break;
        }
        if(e.step > n)
            break;
        q.pop();
        for(int i=head[e.pos];~i;i=edge[i].next){
            int w=edge[i].to;
            if(vis[w] == 1 || vv[w] == 1)
                continue;
            q.push(nod{w,e.step+1});
            vv[w] = 1;
        }
    }
    if(flag == 1)
        printf("%d\n",kk);
    else
       printf("No\n");




    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值