Big Event in HDU【暑期集训DP题】

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002. 
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds). 
InputInput contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different. 
A test case starting with a negative integer terminates input and this test case is not to be processed. 
OutputFor each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B. 
Sample Input
2
10 1
20 1
3
10 1 
20 2
30 1
-1
Sample Output
20 10
40 40

        这是暑期集训第一天过的第一条题,调整状态一用,这道题用到的是背包问题,也是一道基础的背包,接下来我为这道题做些笔记,作为自己的复习资料,也供大家参观。

        这里我将0-1背包做了个活用,一般0-1背包dp[i]中,i为剩余容量,而dp[i]为该容量下的最大价值,我们这里做了些小操作,我将i与dp[i]的功能都做的相同,均为记录此时器材的价值量,那么,我们只需要令dp[i]越加接近中间值即可了。

完整代码

#include <iostream>
#include <cstdio>
using namespace std;
int N;
int v[105],m[105];
int dp[2500005];
int sum=0;
int mid=0;
int main()
{
    while(scanf("%d",&N),N>=0)
    {
        sum=0;
        memset(dp, 0, sizeof(dp));
        for(int i=0; i<N; i++)
        {
            scanf("%d%d",&v[i], &m[i]);
            sum+=v[i]*m[i];
        }
        mid=sum/2;
        for(int i=0; i<N; i++)
        {
            for(int ti=1; ti<=m[i]; ti++)
            {
                for(int j=mid; j>=v[i]*ti; j--)
                {
                    if(dp[j]<dp[j-v[i]]+v[i])
                        dp[j]=dp[j-v[i]]+v[i];
                }
            }
        }
        printf("%d %d\n",sum-dp[mid],dp[mid]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wuliwuliii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值