Super Jumping! Jumping! Jumping!【暑期培训E题】【经典DP】

        说来这道题也是一个飞跃,我一定要详细的记录下来!

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
Your task is to output the maximum value according to the given chessmen list. 
InputInput contains multiple test cases. Each test case is described in a line as follow: 
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
A test case starting with 0 terminates the input and this test case is not to be processed. 
OutputFor each case, print the maximum according to rules, and one line one case. 
Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0
Sample Output
4
10
3

        这道题的目的就是求上升子序列之和,我开始想到的是用DFS来一一找,但过了测试样例之后提交就会发现TE了,后来想想,这节课讲的都是DP当然得用DP来做,我的做法是从第0个元素开始,一直去查到最后一个(n-1)元素,我们记录查到每个元素时候能做到的最大上升和,然后就可以将此时的点作为一个跳板去向下一个节点,因此,只要处理的是一个个点合出这样的ans即可。

完整代码

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
typedef long long ll;
int a[1005];
ll dp[1005];
int n;
ll ans;
int main()
{
    while(scanf("%d",&n)&&n)
    {
        memset(dp, 0, sizeof(dp));
        ans=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            dp[i]=a[i];
        }
        for(int i=0; i<n; i++)
        {
            ll temp=0;
            for(int j=0; j<i; j++)
            {
                if(a[j]<a[i])
                {
                    if(temp<dp[j])
                    {
                        temp=dp[j];
                    }
                }
            }
            dp[i]+=temp;
            ans=max(ans, dp[i]);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wuliwuliii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值