统计难题【字典树】【指针版】

  这道题的难度或许不在于题本身,而是需要输入的字符串需要有一定的难度,这里就得用到gets()的功能,然后其中判断如果字符串的首字符为换行“\0”,那么就退出这重循环。

  还有有一件大事得说,就是关于malloc()和new开空间,他们不能同时使用,关键在于他可能反应出来的不是WA也有可能是TE或者ME,错的多了,也记不得是为什么错了,最后,如果可以的话可以free或者delete释放一下内存(当然,这不会影响最终答案的正确与否)。

题面:

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀). 

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串. 

注意:本题只有一组测试数据,处理到文件结束. 

Output

对于每个提问,给出以该字符串为前缀的单词的数量. 

Sample Input

banana
band
bee
absolute
acm

ba
b
band
abc

Sample Output

2
3
1
0

 

完整代码

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <limits>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#define lowbit(x) ( x&(-x) )
using namespace std;
struct node
{
    int cnt;
    node *child[26];
};
node *root;
void CreatTree(const char s[])
{
    node *now=root;
    //now=(node *)malloc(sizeof(node));
    for(int i=0; s[i]; i++)
    {
        int go=s[i]-'a';
        if(go<0) return;
        if(now->child[go]==NULL)
        {
            now->child[go]=new node();
            now=now->child[go];
            now->cnt=1;
            continue;
        }
        now=now->child[go];
        now->cnt++;
    }
}
int Query(const char s[])
{
    node *now=root;
    //now=(node *)malloc(sizeof(node));
    for(int i=0; s[i]; i++)
    {
        int go=s[i]-'a';
        if(go<0)break;
        if(now->child[go]==NULL) return 0;
        now=now->child[go];
    }
    return now->cnt;
}
int main()
{
    char str[20];
    root=(node *)malloc(sizeof(node));
    memset(str, 0, sizeof(str));
    for(int i=0; i<26; i++) root->child[i]=NULL;
    while(gets(str) && str[0]!='\0')
    {
        CreatTree(str);
        memset(str, 0, sizeof(str));
    }
    while(scanf("%s",str)!=EOF)
    {
        printf("%d\n",Query(str));
        memset(str, 0, sizeof(str));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wuliwuliii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值