Round Numbers【数位DP】

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start.. Finish

Sample Input

2 12

Sample Output

6

  这道题的思路倒是出奇的好想,想了不一会就给我弄出来了,竟然还过了!

  既然是要我们存储的是二进制中0、1的数,那么,我们在solve()的时候,不如就存储二进制数即可,不再存储十进制,作出这样的改变即可!


#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <limits>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#define lowbit(x) ( x&(-x) )
#define pi 3.141592653589793
#define e 2.718281828459045
#define INF 0x3f3f3f3f
using namespace std;
typedef unsigned long long ull;
typedef long long ll;
const int maxN = 32;
int N, M, dp[maxN][maxN][maxN], digit[maxN];
int dfs(int pos, int num0, int num1, bool head, bool limit)
{
    if(pos <= 0) return num0 >= num1;
    if(head && !limit && dp[pos][num0][num1] != -1) return dp[pos][num0][num1];
    int ans = 0;
    int num = limit?digit[pos]:1;
    for(int i=0; i<=num; i++)
    {
        if(i == 0)
        {
            if(head) ans += dfs(pos - 1, num0 + 1, num1, true, limit && i == num);
            else ans += dfs(pos - 1, num0, num1, false, limit && i == num);
        }
        else ans += dfs(pos - 1, num0, num1 + 1, true, limit && i == num);
    }
    if(!limit) dp[pos][num0][num1] = ans;
    return ans;
}
int solve(int x)
{
    int len = 0;
    while(x)
    {
        digit[++len] = x & 1;
        x >>= 1;
    }
    return dfs(len, 0, 0, false, true);
}
int main()
{
    while(scanf("%d%d", &N, &M)!=EOF)
    {
        memset(dp, -1, sizeof(dp));
        printf("%d\n", solve(M) - solve(N-1));
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wuliwuliii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值