Maximum Sequence【HDU 6047】【线段树】

Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it. 

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: an+1…a2nan+1…a2n. Just like always, there are some restrictions on an+1…a2nan+1…a2n: for each number aiai, you must choose a number bkbk from {bi}, and it must satisfy aiai≤max{ajaj-j│bkbk≤j<i}, and any bkbk can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{∑2nn+1ai∑n+12nai} modulo 109109+7 . 

Now Steph finds it too hard to solve the problem, please help him. 

Input

The input contains no more than 20 test cases. 
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}. 
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n. 

Output

For each test case, print the answer on one line: max{∑2nn+1ai∑n+12nai} modulo 109109+7。

Sample Input

4
8 11 8 5
3 1 4 2

Sample Output

27

        
  

Hint

For the first sample:
1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9; 
2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;

        
 

  题意:有一段长度为N的区间,我们想要再构造N个的长度,使之达到2*N的长度,我们的构造是有方案的,就是下面的N行,N个b[i],代表了限制的条件,我们只能在[b[i], j-1](j是目前要构造区间的点,b[i]是限制项,并且每个b[i]只能用一次)中寻找到最大的a[k]-k让它成为a[new]点上的值。

  并且,求出a[N+1]~a[2*N]的和。


#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <limits>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#define lowbit(x) ( x&(-x) )
#define pi 3.141592653589793
#define e 2.718281828459045
#define INF 0x3f3f3f3f
/* 线段树使用头文件 */
#define Lson rt<<1, l, mid
#define Rson rt<<1|1, mid+1, r
#define ques ql, qr
#define HalF (l + r)>>1
#define pushup tree[rt] = max(tree[rt<<1], tree[rt<<1|1])
/*---------------*/
using namespace std;
typedef unsigned long long ull;
typedef long long ll;
const ll mod = 1e9 + 7;
const int maxN = 5e5 + 7;
int N, b[maxN], tree[maxN<<2];
void buildTree(int rt, int l, int r)
{
    if(l == r)
    {
        if(l <= N)
        {
            scanf("%d", &tree[rt]);
            tree[rt] -= l;
        }
        else tree[rt] = -INF;
        return;
    }
    int mid = HalF;
    buildTree(Lson);
    buildTree(Rson);
    pushup;
}
inline void update(int rt, int l, int r, int qx, int val)
{
    if(l == r) { tree[rt] = val; return; }
    int mid = HalF;
    if(qx<=mid) update(Lson, qx, val);
    else update(Rson, qx, val);
    pushup;
}
int query(int rt, int l, int r, int ql, int qr)
{
    if(ql <= l && qr >= r) return tree[rt];
    int mid = HalF;
    if(ql > mid) return query(Rson, ques);
    else if(qr <= mid) return query(Lson, ques);
    else return max(query(Lson, ques), query(Rson, ques));
}
int main()
{
    while(scanf("%d", &N)!=EOF)
    {
        buildTree(1, 1, 2*N);
        for(int i=1; i<=N; i++) scanf("%d", &b[i]);
        sort(b+1, b+1+N);
        ll ans = 0;
        int tmp;
        for(int i=1; i<=N; i++)
        {
            tmp = query(1, 1, 2*N, b[i], i + N - 1);
            ans += tmp;
            update(1, 1, 2*N, i+N, tmp - i - N);
            ans %= mod;
        }
        printf("%lld\n", ans);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wuliwuliii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值