HDU-6025-coprime sequence

HDU-6025-coprime sequence

Do you know what is called Coprime Sequence''? That is a sequence consists of n positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.
Coprime Sequence” is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

Input
The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.
In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of integers in the sequence.
Then the following line consists of n integers a1,a2,…,an(1≤ai≤109), denoting the elements in the sequence.

Output
For each test case, print a single line containing a single integer, denoting the maximum GCD.

Sample Input
3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8
Sample Output
1
2
2

大意:就是给n个数,让你去掉一个使剩下的数最大公约数最大。

思路:主要是做题的思路,对里面的每个数都去掉一遍,不过是换个方法,就是去掉第 i 个数,就是求
剩下的最大公约数,用两个数组从两头按顺序存放最大公约数。

#include<stdio.h>
#include<algorithm>
using namespace std;
int gcd(int a,int b)
{
    return b?gcd(b,a%b):a; 
}
int a[100010],l[100010],r[100010]; 
int main()
{
    int t,n,i;
    scanf("%d",&t);
    while(t--)
    {
        int ans,num;
        scanf("%d",&n);
        for(i = 1;i <= n; i ++) 
            scanf("%d",&a[i]);
        l[1] = a[1];r[n] = a[n]; 

        for(i = 2;i <= n; i++)  //l数组是左边i-1位数的最大公约数 
            l[i] = gcd(a[i],l[i-1]);

        for(i = n-1; i >= 1; i--)  //r数组是右边i+1到n的最大公约数 
            r[i] = gcd(a[i],r[i+1]);

        ans = max(l[n-1],r[2]);  //下面的就是遍历,然后取最大 
        for(i = 2;i < n; i ++)
            ans = max(ans,gcd(l[i-1],r[i+1]));

        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值