HDU 2017 多校联赛2 1003 Maximum Sequence

Problem Description

Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: an+1…a2n. Just like always, there are some restrictions on an+1…a2n: for each number ai, you must choose a number bk from {bi}, and it must satisfy ai≤max{aj-j│bk≤j< i}, and any bk can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{∑2nn+1ai} modulo 109+7 .

Now Steph finds it too hard to solve the problem, please help him.

Input

The input contains no more than 20 test cases. 
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}. 
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.

Output

For each test case, print the answer on one line: max{∑2nn+1ai} modulo 109+7。

Sample Input


8 11 8 5 
3 1 4 2

Sample Output

27

Hint

For the first sample: 
1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9; 
2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;

题目大意:

输入一个数s,接下来有两个数组m,n,求m数组从s+1到2s和的最大值。数组m从s+1到2s的计算规则m[i]≤max{m[j]-j│n[k]≤j< i};并且n数组中的数字每个只能取一次。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
const int ll = 1e9 + 7;
using namespace std;
int m[5000010],n[250010],s[5000010];
int main()
{
    long long int a,b,c,d,e,f,h;
    while(~scanf("%lld",&a))
    {
        f=0;h=0;
        for(b=0;b<a;b++)
        {
            scanf("%lld",&m[b]);
        }
        for(d=0;d<a;d++)
        {
            scanf("%lld",&n[d]);
        }
        sort(n,n+a);
        for(b=a-1;b>=0;b--)
        {
            if((m[b]-b-1)>h)
                h=(m[b]-b-1);
            s[b]=h;
        }
        e=-1;
        for(b=0;b<a;b++)
        {
            if(s[n[b]-1]>e)
                s[a+b]=s[n[b]-1];
            else
                s[a+b]=e;
            if(s[a+b]-a-b-1>e)
                e=s[a+b]-a-b-1;
            f=f+s[a+b];
            f=f%ll;
        }
        cout<<f<<endl;
    }
    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值