poj 2155 Matrix//二维树状数组求和(模板)

poj 2155 Matrix//二维树状数组求和(模板)

Matrix

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 34469 Accepted: 12482

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

 https://blog.csdn.net/bestsort/article/details/80796531#%E6%9F%A5%E8%AF%A2-1

%%% 具体证明推导tql了!!!

这里运用的还是差分思想了。

我分别用区间修改+单点查询,区间修改+区间查询试了两发

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long ll;
const int N = 1005;
ll n, m;
ll tree[N][N];
void add(int x, int y, int z){
    int memo_y = y;
    while(x <= n){
        y = memo_y;
        while(y <= n)
            tree[x][y] += z, y += y & -y;
        x += x & -x;
    }
}
void range_add(int xa, int ya, int xb, int yb, int z){//(xa, ya) 到 (xb, yb) 的矩形
    add(xa, ya, z);
    add(xa, yb + 1, -z);
    add(xb + 1, ya, -z);
    add(xb + 1, yb + 1, z);
}
ll ask(int x, int y){
    int res = 0, memo_y = y;
    while(x){
        y = memo_y;
        while(y)
            res += tree[x][y], y -= y & -y;
        x -= x & -x;
    }
    return res;
}
int main(){
    int T,Q;scanf("%d",&T);while(T--){
        scanf("%d%d",&n,&Q);m=n;
        for(int i=0;i<=n+1;i++)for(int j=0;j<=n+1;j++){
            tree[i][j]=0;
        }
        while(Q--){
            getchar();
            char op;int x1,y1,x2,y2;
            scanf("%c",&op);
            if(op=='C'){
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                range_add(x1,y1,x2,y2,1);
            }
            else {
                scanf("%d%d",&x1,&y1);
                printf("%d\n",ask(x1,y1)%2);
            }
        }
        puts("");
    }
    return 0;
}
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long ll;
const int N = 1005;
ll n, m;
ll t1[N][N], t2[N][N], t3[N][N], t4[N][N];
void add(ll x, ll y, ll z){
    for(int X = x; X <= n; X += X & -X)
        for(int Y = y; Y <= m; Y += Y & -Y){
            t1[X][Y] += z;
            t2[X][Y] += z * x;
            t3[X][Y] += z * y;
            t4[X][Y] += z * x * y;
        }
}
void range_add(ll xa, ll ya, ll xb, ll yb, ll z){ //(xa, ya) 到 (xb, yb) 的矩形
    add(xa, ya, z);
    add(xa, yb + 1, -z);
    add(xb + 1, ya, -z);
    add(xb + 1, yb + 1, z);
}
ll ask(ll x, ll y){
    ll res = 0;
    for(int i = x; i; i -= i & -i)
        for(int j = y; j; j -= j & -j)
            res += (x + 1) * (y + 1) * t1[i][j]
                - (y + 1) * t2[i][j]
                - (x + 1) * t3[i][j]
                + t4[i][j];
    return res;
}
ll range_ask(ll xa, ll ya, ll xb, ll yb){
    return ask(xb, yb) - ask(xb, ya - 1) - ask(xa - 1, yb) + ask(xa - 1, ya - 1);
}
int main(){
    int T,Q;scanf("%d",&T);while(T--){
        scanf("%d%d",&n,&Q);m=n;
        for(int i=0;i<=n+1;i++)for(int j=0;j<=n+1;j++){
            t1[i][j]=0;t2[i][j]=0;t3[i][j]=0;t4[i][j]=0;
        }
        while(Q--){
            getchar();
            char op;int x1,y1,x2,y2;
            scanf("%c",&op);
            if(op=='C'){
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                range_add(x1,y1,x2,y2,1);
            }
            else {
                scanf("%d%d",&x1,&y1);x2=x1,y2=y1;
                printf("%d\n",range_ask(x1,y1,x2,y2)%2);
            }
        }
        puts("");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值