poj1142 Smith Numbers(素数+唯一分解定理)

传送门:Smith Numbers

While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way: 

4937775= 3*5*5*65837


The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers. 
As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition. 
Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!

Input

The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.

Output

For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.

Sample Input

4937774
0

Sample Output

4937775

题意:

找到比n大的第一个本身不是素数且分解成质因子后的各个数位之和等于其本身各个数位之和的数。

思路:

将改数字分解成质因数,暴力判断即可。

AC代码:

//#include <bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N = 1e5 + 7;
const int inf = 0x3f3f3f3f;
const int mod = 1e9 + 7;

int prime[N],cnt,num_prime[N];
bool isprime[N];
int num_pos(int tmp)
{
    int sum = 0;
    while(tmp){
        sum += (tmp % 10);
        tmp /= 10;
    }
    return sum;
}
void get_prime()
{
    for(int i = 2;i < N;++i)
        if(!isprime[i]){
            prime[++cnt] = i;
            num_prime[cnt] = num_pos(i);
            for(int j = i + i;j < N;j += i) isprime[j] = true;
        }
}
bool judge(int pos)
{
    if(pos < N && !isprime[pos]) return false;
    int index = 0,tmp = pos;
    for(int i = 1;i <= cnt && prime[i] * prime[i] <= pos;++i){
        if(pos % prime[i] == 0){
            while(pos % prime[i] == 0){
                pos /= prime[i];
                index += num_prime[i];
            }
        }
    }
    if(pos > 1 && !index) return false;
    if(pos > 1) index += num_pos(pos);
    return num_pos(tmp) == index;
}
int main()
{
    get_prime();
    int n;
    while(scanf("%d",&n) != EOF && n){
        for(int i = n + 1;;++i)
            if(judge(i)){
                printf("%d\n",i);
                break;
            }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值