POJ-3259.Wormholes(SPFA算法)

3259.Wormholes

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2…M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2…M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1…F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

spfa算法

这道题是 判断图中是否有负环图,所以spfa算法比较合适的,spfa算法可以检验是否存在负环图,我们设定一个队列,来保存被拓展的点,当有点的入队次数大于等于n时,说明图中存在负环图。

#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;

const int maxv = 1000;
const int INF = 0x3f3f3f3f;

struct Node{ 
    int v;
    int dist;
    Node(int v,int d){
        this->v = v;
        this->dist = d;
    }
};

vector<Node> G[maxv]; // 邻接表
int dist[maxv]; // 记录最短路径
int ranks[maxv]; // 记录每个点的入队次数
bool book[maxv]; // 标记被拓展过的点

bool spfa(int s,int n){
    fill(dist,dist + n + 1,INF);
    fill(ranks,ranks + n + 1,0);
    fill(book,book + n + 1,false);
    queue<int> que;
    ranks[s] = 1;
    book[s] = true;
    dist[s] = 0;
    que.push(s);
    while(!que.empty()){
        int u = que.front();
        que.pop();
        book[u] = false; 
        for(size_t i = 0;i < G[u].size();i++){
            Node e = G[u][i];
            if(dist[e.v] > dist[u] + e.dist){
                dist[e.v] = dist[u] + e.dist;
                if(!book[e.v]){
                    que.push(e.v);
                    book[e.v] = true;
                    ranks[e.v]++; // 当有点入队次数等于n时,说明有负环
                    if(ranks[e.v] >= n ) return false; 
                }
            }
        }
    }
    return true;
}
int main(){
    //freopen("test.txt","r",stdin);
    int t,n,m,w;
    cin >> t;
    while(t--){
        cin >> n >> m >> w;
        for(int i = 0;i <= n; i++) G[i].clear();
        for(int i = 0;i < m; i++){
            int u, v, d;
            cin >> u >> v >> d;
            G[u].push_back(Node(v,d));
            G[v].push_back(Node(u,d));
        }
        for(int i = 0; i < w; i++){
            int u, v, d;
            cin >> u >> v >> d;
            G[u].push_back(Node(v,-d));
        }
        /* for(int i = 1; i <= n; i++){ */
        /*     G[n+1].push_back(Node(i,0)); */
        /* } */
        if(spfa(1,n)) puts("NO");
        else puts("YES");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值