Intersecting Lines(叉积的运用)

E - Intersecting Lines

Time Limit: 1000 MS Memory Limit: 10000 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status]

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

题目大意:给你四个点坐标,分别代表两条直线,如果两条直线重合输出LINE,平行输出NONE,相交输出POINT 相交坐标

解题思路:叉积证明平行和重合。相交用如下证明

证明:

直线的一般方程为F(x)=ax+by+c=0F(x)=ax+by+c=0。既然我们已经知道直线的两个点,假设为(x0,y0),(x1,y1)(x0,y0),(x1,y1),那么可以得到a=y0y1a=y0−y1b=x1x0b=x1–x0c=x0y1x1y0c=x0y1–x1y0

两点式直线方程可证:

因此我们可以将两条直线分别表示为

F0(x)=a0x+b0y+c0=0,F1(x)=a1x+b1y+c1=0F0(x)=a0x+b0y+c0=0,F1(x)=a1x+b1y+c1=0

那么两条直线的交点应该满足

a0x+b0y+c0=a1x+b1y+c1a0x+b0y+c0=a1x+b1y+c1

由此可推出

x=(b0c1b1c0)/D

y=(a1c0a0c1)/D

D=a0b1a1b0D=a0b1−a1b0

 (D为0时,表示两直线平行)

#include<iostream>
#include<math.h>
#include<algorithm>
#include<stdio.h>
#include<map>
#define LL long long
using namespace std;
int main()
{
    int t;
    double x1,x2,x3,x4,y1,y2,y3,y4;
    scanf("%d",&t);
    cout<<"INTERSECTING LINES OUTPUT"<<endl;
    while(t --)
    {
        cin>>x1>>y1>>x2>>y2>>x3>>y3>>x4>>y4;
        double a0,b0,a1,b1,c0,c1;
        a0 = y1-y2;
        a1 = y3-y4;
        b0 = x2-x1;
        b1 = x4-x3;
        c0 = x1*y2-y1*x2;
        c1 = x3*y4-y3*x4;
        if(a0*b1 == b0*a1)
        {
            if((x1-x3)*(y1-y2) == (x1-x2)*(y1-y3))
            {
                cout<<"LINE"<<endl;///重合
            }
            else
            {
                cout<<"NONE"<<endl;
            }
        }
        else
        {
            double d = a0*b1-b0*a1;
            double x = (b0*c1-b1*c0)/d;
            double y = (a1*c0-a0*c1)/d;
            printf("POINT %.2f %.2f\n",x,y);
        }
    }
    cout<<"END OF OUTPUT"<<endl;
}

参考博客:

收藏
614

两点式

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值