【UVA 253 --- Cube painting】

【UVA 253 --- Cube painting】

题目来源:点击进入【UVA 253 — Cube painting】

Description

Input

The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a
string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the
remaining 6 characters give you the representation of another cube. Your program determines whether
these two cubes are painted in the same way, that is, whether by any combination of rotations one can
be turned into the other. (Reflections are not allowed.)

Output

The output is a file of boolean. For each line of input, output contains ‘TRUE’ if the second half can be
obtained from the first half by rotation as describes above, ‘FALSE’ otherwise.

Sample Input

rbgggrrggbgr
rrrbbbrrbbbr
rbgrbgrrrrrg

Sample Output

TRUE
FALSE
FALSE

解题思路

根据题意我们只需判断正方体的三个互相垂直的面以及与其相对的那个面在另外一个正方形中是否能找到即可。当然找到过的需要去掉。

AC代码:

#include <stdio.h>
char s[15],s1[8],s2[8];

int main()
{
    while(~scanf("%s",s))
    {
        for(int i=0;i<6;i++)
            s1[i]=s[i],s2[i]=s[i+6];
        bool flag=false;
        for(int i=0;i<3;i++)
        {
            flag=false;
            for(int j=0;j<6;j++)
            {
                if(s1[i]!=s2[j] || s1[5-i]!=s2[5-j]) continue;
                flag=true;
                s2[j]=s2[5-j]='#';
                break;
            }
            if(!flag) break;
        }
        if(flag) printf("TRUE\n");
        else printf("FALSE\n");
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值