Palindrome (再加多少个字符才能成为回文串 dp)

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

题意:求长度为n的字符串,最少再加几个字符才能构成回文串。

思路:首先我们可以根据回文串的定义知道:一个回文串的正序字符串==自身的逆序字符串的。我们此时是要构造一个回文串,那么我们就取它的逆序串,目标是使这两个串完全相等。我们可以求一下这两个字符串中有哪些字符是按照一定的顺序连续相等的(即最长公共子序列),那么这些字符是已经找到对应的字符了,此时每个字符串里面还有n-dp[n][n]个字符没有匹配上,因此我们只需要在适当的位置加上剩余字符的对应字符即可,具体在哪不是这道题要求的。综合来说,这道题就是求 n - 此字符串正逆序的最长公共子序列的长度。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[5050],t[5050];
unsigned short dp[5001][5001];  //数据太大,用无符号短整型减少内存
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        scanf("%s",s);   //正序
        for(int j=0,i=n-1; i>=0; i--,j++)
            t[j]=s[i];   //逆序
        memset(dp,0,sizeof(dp));  //dp数组初始化
        for(int i=0; i<n; i++) //求最长公共子序列的长度
            for(int j=0; j<n; j++)
                if(s[i]==t[j])
                    dp[i+1][j+1]=dp[i][j]+1;
                else
                    dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);
        printf("%d\n",n-dp[n][n]);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值