Primes (素数打表)

Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes. 

Input

Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000. 

Output

The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by "yes" or "no". 

Sample Input

1
2
3
4
5
17
0

Sample Output

1: no
2: no
3: yes
4: no
5: yes
6: yes

题意:给出几个数判断一下是不是素数,是的话输出yes,不是的话输出no。

思路:用素数打表法,当一个数是素数时,它的倍数肯定不是素数,然后注意一下这个题是小于等于0时结束。代码如下:

#include<stdio.h>
#include<string.h>
int a[16010];
int main()
{
    int n,i,j,k=1;
    memset(a,0,sizeof(a));
    for (i = 2; i<=16010; i++)
    {
        if (a[i]==0)  //0是素数
        {
            for (j=i+i; j<=16010; j+=i)
                a[j]=1;
        }
    }
    a[1]=1;a[2]=1;
    while(~scanf("%d",&n))
    {
        if(n<=0)
            break;
        if(a[n]==0)
            printf("%d: yes\n",k++);
        else
            printf("%d: no\n",k++);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值