GCD and LCM (素因子分解)

Given two positive integers G and L, could you tell me how many solutions of (x, y, z) there are, satisfying that gcd(x, y, z) = G and lcm(x, y, z) = L? 
Note, gcd(x, y, z) means the greatest common divisor of x, y and z, while lcm(x, y, z) means the least common multiple of x, y and z. 
Note 2, (1, 2, 3) and (1, 3, 2) are two different solutions.

Input

First line comes an integer T (T <= 12), telling the number of test cases. 
The next T lines, each contains two positive 32-bit signed integers, G and L. 
It’s guaranteed that each answer will fit in a 32-bit signed integer.

Output

For each test case, print one line with the number of solutions satisfying the conditions above.

Sample Input

2 
6 72 
7 33 

Sample Output

72 
0

题意:T组数据,每组数据一个G,L。G=gcd(x1,x2,x3) L=lcm(x1,x2,x3)求符合条件的所有情况的个数。有序...

GCD =  p1 ^ min(a1,b1,c1) * p2 ^min(a2,b2,c2) * ... * pn ^min(an,bn,cn)

LCM =  p1 ^ max(a1,b1,c1) * p2 ^max(a2,b2,c2) * ... * pn ^max(an,bn,cn)

现在我们能得到 指数:

 n = max - min +1;

当 n == 1 时 只有一种情况

当 n == 2时  (a a b) (a b b) 又因为是有序,所以有6种

当 n >=3 时  (a a b) (a b b) 和上面一样 + (a b c)排序后又6种

代码如下:

#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<map>
#include<string>
#include<queue>
#include<iostream>
#include<algorithm>
#define inf 0x3f3f3f3f
#define ll long long
#define N 100010
using namespace std;
ll p1[N],p2[N],a1[N],a2[N];
map<ll,ll>v,u;
int work(ll *a,ll x,int flag)
{
	int ans=0;
	for(ll i=2;i*i<=x;i++)
	{
		if(x%i==0)
		{
			ll t=i;
			a[ans++]=i;
			while(x%i==0)
			{
				x/=i;
				if(flag)v[t]++;
				else u[t]++;
			}
		}
	}
	//printf("///%lld\n",x);
	if(x!=1)
	{
		a[ans++]=x;
		if(flag)v[x]++;
		else u[x]++;
	}
	return ans;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		ll G,L;
		v.clear(),u.clear();
		scanf("%lld %lld",&G,&L);
		int n=work(a1,G,1);
		int m=work(a2,L,0);
		int flag=0;
		for(int i=0;i<n;i++)
		{
			ll x=a1[i];
			if(u[x]<v[x])
			{
				flag=1;
				break;
			}
		}
		if(flag)printf("0\n");
		else
		{
			ll sum=1;
			for(int i=0;i<m;i++)
			{
				int x=a2[i];
				ll a=u[x]-v[x]+1;
				if(a==2)sum*=6;
				else if(a>2)
					sum=sum*(6+(a-2)*6);
			}
			printf("%lld\n",sum);
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值