1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

 层序遍历与中序遍历的应用,与常规不同的是需要先将右孩子入队/递归。即可得到正确答案

代码如下:


#include<iostream>
#include<string>
#include<algorithm>
#include<set>
#include<queue>
#include<vector>
using namespace std;
int n;
struct TNode{
	int id;
	string left, right;
}tnode[12];
int p[12];
queue<int> qu;
int cnt = 1;
void Inorder(int root) {
	if (tnode[root].right != "-") {
		int tmp = stoi(tnode[root].right);
		Inorder(tmp);
	}
	if (cnt == 1) {
		cout << root;
		cnt--;
	}
	else cout << " " << root;
	if (tnode[root].left != "-") {
		int tmp = stoi(tnode[root].left);
		Inorder(tmp);
	}
}
int main() {
	cin >> n;
	for (int i = 0; i < n; i++) {
		p[i] = -1;
	}
	for (int i = 0; i < n; i++) {
		cin >> tnode[i].left >> tnode[i].right;
		tnode[i].id = i;
		if (tnode[i].left != "-") {
			int tmp = stoi(tnode[i].left);
			p[tmp] = i;
		}
		if (tnode[i].right != "-") {
			int tmp = stoi(tnode[i].right);
			p[tmp] = i;
		}
	}
	int root;
	for (int i = 0; i < n; i++) {
		if (p[i] == -1) root = i;
	}
	qu.push(root);
	while (!qu.empty()) {
		int tp = qu.front();
		qu.pop();
		if (tp == root) cout << tp;
		else cout << " " << tp;
		if (tnode[tp].right != "-") {
			int tmp = stoi(tnode[tp].right);
			qu.push(tmp);
		}
		if (tnode[tp].left != "-") {
			int tmp = stoi(tnode[tp].left);
			qu.push(tmp);
		}
	}
	cout << endl;
	Inorder(root);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值