1107 Social Clusters (30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

#include<iostream>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
int n;
int hb[1010] = { 0 };
int pnt[1010];
void uni(int x, int y);
int findroot(int x);
bool cmp(int a, int b) {
	return a > b;
}
int main() {
	cin >> n;
	for (int i = 0; i <= n; i++) {
		pnt[i] = i;
	}
	for (int i = 1; i <= n; i++) {
		int k;
		scanf("%d", &k);
		getchar();
		for (int j = 0; j < k; j++) {
			int h;
			scanf("%d", &h);
			if (hb[h] == 0)
				hb[h] = i;
			else uni(findroot(hb[h]), i);
		}
	}
	int cnt = 0;
	int count[1010] = { 0 };
	for (int i = 1; i <= n; i++) {
		count[findroot(i)]++;
	}
	for (int i = 1; i <= n; i++) {
		if (count[i] != 0) cnt++;
	}
	printf("%d\n", cnt);
	sort(count + 1, count + n + 1, cmp);
	for (int i = 1; i <= cnt; i++) {
		if (i == 1) printf("%d", count[i]);
		else printf(" %d", count[i]);
	}
	return 0;
}
void uni(int x, int y) {
	int root1, root2;
	root1 = findroot(x);
	root2 = findroot(y);
	if (root1 != root2) pnt[root2] = root1;
}
int findroot(int x) {
	while (pnt[x] != x) {
		x = pnt[x];
	}
	return x;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值