【题解】CH3602Counting Swaps 组合计数+快速幂+逆元

题目链接

背景

https://ipsc.ksp.sk/2016/real/problems/c.html

Just like yesterday (in problem U of the practice session), Bob is busy, so Alice keeps on playing some single-player games and puzzles. In her newest puzzle she has a permutation of numbers from 1 to n. The goal of the puzzle is to sort the permutation using the smallest possible number of swaps.

Instead of simply solving the puzzle, Alice is wondering about the probability of winning it just by playing at random. In order to answer this question, she needs to know the number of optimal solutions to her puzzle.

描述

给定一个 1~n 的排列 p_1,p_2,…,p_n,可进行若干次操作,每次选择两个整数 x,y,交换 p_x,p_y。设把 p_1,p_2,…,p_n 变成单调递增的排列 1,2,…,n 至少需要 m 次交换。求有多少种操作方法可以只用 m 次交换达到上述目标。因为结果可能很大,你只需要输出对 10^9+9 取模之后的值。1≤n≤10^5。
例如排列 2,3,1 至少需要2次交换才能变为 1,2,3。操作方法共有3种,分别是:
先交换数字2,3,变成 3,2,1,再交换数字3,1,变成 1,2,3。
先交换数字2,1,变成 1,3,2,再交换数字3,2,变成 1,2,3。
先交换数字3,1,变成 2,1,3,再交换数字2,1,变成 1,2,3。
You are given a permutation p1, …, pn of the numbers 1 through n. In each step you can choose two numbers x < y and swap px with py.

Let m be the minimum number of such swaps needed to sort the given permutation. Compute the number of different sequences of exactly m swaps that sort the given permutation. Since this number may be large, compute it modulo 109 + 9.

输入格式

The first line of the input file contains an integer t specifying the number of test cases. Each test case is preceded by a blank line.

Each test case consists of two lines. The first line contains the integer n. The second line contains the sequence p1, …, pn: a permutation of 1, …, n.

In the easy subproblem C1, 1 ≤ n ≤ 10.

In the hard subproblem C2, 1 ≤ n ≤ 105.

输出格式

For each test case, output a single line with a single integer: x , where x is the number of ways to sort the given sequence using as few swaps as possible.

样例输入

3

3
2 3 1

4
2 1 4 3

2
1 2

样例输出

3
2
1

样例解释

In the first test case, we can sort the permutation in two swaps. We can make the first swap arbitrarily; for each of them, there’s exactly one optimal second swap. For example, one of the three shortest solutions is “swap p1 with p2 and then swap p1 with p3”.

In the second test case, the optimal solution involves swapping p1 with p2 and swapping p3 with p4. We can do these two swaps in either order.

The third sequence is already sorted. The optimal number of swaps is 0, and thus the only optimal solution is an empty sequence of swaps.


推导过程详见李煜东《算法竞赛进阶指南》

#include<cstdio>
typedef long long ll;
const int N=1e5+10;
const int mod=1e9+9;
int n,t,len,cnt,p[N];
bool vis[N];
ll f[N],jc[N],ans;
ll qpow(ll a,ll b)
{
    ll ret=1;
    for(;b;b>>=1)
    {
        if(b&1)ret=ret*a%mod;
        a=a*a%mod;
    }
    return ret;
}
int main()
{
    //freopen("in.txt","r",stdin);
    jc[0]=1;
    for(int i=1;i<=1e5;i++)jc[i]=jc[i-1]*i%mod;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);cnt=0;ans=1;
        for(int i=1;i<=n;i++)scanf("%d",&p[i]),vis[i]=false;
        for(int i=1;i<=n;i++)
        {
            if(vis[i])continue;
            vis[i]=true;len=1;
            for(int j=p[i];j!=i;j=p[j])vis[j]=true,len++;
            cnt++;
            ans=(ans*(len==1?1:qpow(len,len-2))%mod)*qpow(jc[len-1],mod-2)%mod;
        }
        ans=ans*jc[n-cnt]%mod;
        printf("%lld\n",ans);
    }
    return 0;
}

总结

一波复杂的公式推导……

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值