Description
Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.
Input
Input starts with an integer T (≤ 525), denoting the number of test cases.
Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.
Output
For each case, print the case number first. Then print ‘divisible’ if a is divisible by b. Otherwise print ‘not divisible’.
Sample Input
6
101 101
0 67
-101 101
7678123668327637674887634 101
11010000000000000000 256
-202202202202000202202202 -101
Sample Output
Case 1: divisible
Case 2: divisible
Case 3: divisible
Case 4: not divisible
Case 5: divisible
Case 6: divisible
一位一位边读入边取模
#include<cstdio>
#include<cstring>
#include<cctype>
typedef long long ll;
int t;
char s[510];
ll b,num;
int main()
{
//freopen("in.txt","r",stdin);
scanf("%d",&t);
for(int ca=1;ca<=t;ca++)
{
printf("Case %d: ",ca);
scanf("%s%lld",s,&b);
num=0;
for(int i=0;i<strlen(s);i++)
if(isdigit(s[i]))
num=(num*10+s[i]-'0')%b;
if(num==0)puts("divisible");
else puts("not divisible");
}
return 0;
}
总结
大整数取模