【题解】LightOJ1214 Large Division 数学知识

该博客主要介绍了如何判断两个大整数是否满足除法关系,即一个数是否能被另一个数整除。通过给出的样例输入和输出,解释了判断条件和处理大整数的方法,特别提到了逐位取模的策略。
摘要由CSDN通过智能技术生成

题目链接

Description

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print ‘divisible’ if a is divisible by b. Otherwise print ‘not divisible’.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible


一位一位边读入边取模

#include<cstdio>
#include<cstring>
#include<cctype>
typedef long long ll;
int t;
char s[510];
ll b,num;
int main()
{
    //freopen("in.txt","r",stdin);
    scanf("%d",&t);
    for(int ca=1;ca<=t;ca++)
    {
        printf("Case %d: ",ca);
        scanf("%s%lld",s,&b);
        num=0;
        for(int i=0;i<strlen(s);i++)
            if(isdigit(s[i]))
                num=(num*10+s[i]-'0')%b;
        if(num==0)puts("divisible");
        else puts("not divisible");
    }
    return 0;
}

总结

大整数取模

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值