A + B Problem II

A + B Problem II

题目:
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

代码如下:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
#define MAX 1005

char a[MAX],b[MAX];
int  aa[MAX],bb[MAX],sum[MAX + 1];

int main()
{
    int n,len_a,len_b,max_len,maxn,k;
    cin >> n;
    for(int i = 1;i <= n;i++)
    {
        memset(aa,0,sizeof(aa));
        memset(bb,0,sizeof(bb));
        memset(sum,0,sizeof(sum));
        cin >> a >> b;
        len_a = strlen(a);
        len_b = strlen(b);
        k = 0;
        for(int j = len_a - 1;j >= 0;j--) aa[k++] = a[j] - 48;
        k = 0;
        for(int j = len_b - 1;j >= 0;j--) bb[k++] = b[j] - 48;
        max_len = max(len_a,len_b);
        for(int j = 0;j < max_len;j++)
        {
            sum[j] += aa[j] + bb[j];
            maxn = j;
            if(sum[j] >= 10)
            {
                sum[j] -= 10;
                sum[j + 1]++;
                maxn = j + 1;
            }
        }
        cout << "Case " << i << ":" << endl;
        for(int j = 0;j < len_a;j++) cout << a[j];
        cout << " + " ;
        for(int j = 0;j < len_b;j++) cout << b[j];
        cout << " = ";
        for(int j = maxn;j >= 0;j--) cout << sum[j];//maxn为最大位数
        cout << endl;
        if(i != n) cout << endl;
    }
    return 0;
}

这道题如果普通的进行加法操作肯定会超范围的(long long也不行),所以只能使用字符数组来进行操作了,把输入的每一位都用转为int型,并用数组保存,随后一位对一位求和,如果相加之和超过10,则这一位要减去10,并且要进位。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值